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NOTICES and SOFTWARE LICENSING AGREEMENT
Copyright and Trademarks

Copyright © 2019 Christie Digital Systems USA Inc. All rights reserved.

All brand names and product names are trademarks, registered trademarks or trade names of their respective holders.

General

Every effort has been made to ensure accuracy, however in some cases changes in the products or availability could occur which may not be reflected in this
document. Christie reserves the right to make changes to specifications at any time without notice. Performance specifications are typical, but may vary
depending on conditions beyond Christie's control such as maintenance of the product in proper working conditions. Performance specifications are based on
information available at the time of printing. Christie makes no warranty of any kind with regard to this material, including, but not limited to, implied
warranties of fitness for a particular purpose. Christie will not be liable for errors contained herein or for incidental or consequential damages in connection
with the performance or use of this material. Canadian manufacturing facility is ISO 9001 and 14001 certified.

SOFTWARE LICENSING AGREEMENT
Agreement

a. This Software License Agreement (the “Agreement”) is a legal agreement between the end user, either an individual or business entity, (“Licensee”) and
Christie Digital Systems USA, Inc. (“Christie”) for the software known commercially as Christie® Mystique Install that accompanies this Agreement
and/or is installed in the server that Licensee has purchased along with related software components, which may include associated media, printed
materials and online or electronic documentation (all such software and materials are referred to herein, collectively, as “Software”). If Licensee does not
accept the terms of this Agreement, Licensee will return the Software to Christie in accordance with Christie's standard return policy in place from time
to time. BY DOWNLOADING, INSTALLING, ACTIVATING OR USING THE SOFTWARE, THE LICENSEE IS AGREEING TO BE BOUND BY THE TERMS OF THIS
AGREEMENT.

b. The Software contains third party software programs which require notices and/or additional terms and conditions. Such required third party notices
and/or additional terms and conditions are located in the Mystique Install application (Help > About). By accepting this Agreement and using the
Software, you are also accepting any such additional terms and conditions applicable to the third party software programs. To the extent any license for
third party software programs requires an offer to provide source code for those third party software programs, this Agreement constitutes such an offer.
You may request more information or a copy of such source code by contacting Christie at open.source@christiedigital.com. In conjunction with such
request, provide the Christie Product Number, the Software version and the Product Serial Number (if applicable). If applicable, a nominal cost to cover
shipping and media charges will be charged.

License and Restrictions

a. Ownership of Software: Christie retains title and ownership of all rights, including copyright and all other intellectual property rights, in and to the
Software and all copies thereof, regardless of form or media. This license is not a sale of any rights in or to the Software or any copy thereof. Licensee
acquires no right whatsoever to the Software except the right to use the Software in accordance with the terms of this License.

b. Grant of License: Christie grants to Licensee a single license providing a nonexclusive and non-transferable right to use, for personal or internal
business purposes, the executable version of the Software, as long as Licensee complies with the terms and conditions of this License. Christie reserves
all rights not expressly granted to Licensee.

c. Copy Restrictions: Where the Software is provided for download onto a personal computer or similar device, Licensee may make as many copies of the
Software as is reasonably required for Licensee's own use with the Device. Licensee may also make a backup copy of the Software which may be used
only for reinstallation of the Software. Where the software is pre-installed on a server, Licensee may keep one copy of the Software solely for backup or
archival purposes. Unauthorized copying or distribution of the Software is expressly prohibited unless agreed to in writing by Christie. Licensee must
reproduce and include the copyright notice on any backup copy of the Software. Licensee may not remove or alter any proprietary rights or copyright
notice or identification which indicates the ownership of the Software.

d. Use Restrictions: Licensee will not (a) modify, adapt, decompile, disassemble, reverse engineer, or otherwise attempt to derive the source code for the
Software, or create derivative works based on the Software; (b) assign this Agreement or redistribute, encumber, sell, transfer, lease, or grant a
sublicense of the Software or the license granted herein or otherwise transfer rights to the Software to any person or entity except as and when
expressly permitted by this Agreement; (c) directly or indirectly, export or transmit the Software, either alone or bundled with other software, to any
country to which such export or transmission is restricted by any applicable laws without the appropriate prior written consent of the applicable
government entity or department; and (d) publish or otherwise disclose the Software for others to copy. Licensee will make reasonable efforts to prevent
any unauthorized use of the Software by third parties and will advise Licensee's employees of the restrictions upon use restrictions herein.

e. Upgrades and Updates: While Christie is not required to do so, Christie may provide Licensee with upgrades or updates to the Software, including but
not limited to files that are delivered to Licensee via online transmission or otherwise to “patch” or otherwise modify or enhance the software program.
This Agreement covers any upgrades or updates to the Software that Licensee may obtain from Christie or one of its authorized vendors, unless the
upgrade or update comes with its own license agreement. If Licensee decides not to download or install an upgrade or update provided by Christie,
Licensee understands that this could put the Software at risk to serious security threats or cause the Software to be come unstable. Christie may, at its
option, cause an upgrade or update to apply automatically.

Maintenance and Support

a. Christie may, in its sole discretion and without any obligation, provide maintenance and support services related to the Software (“Support Services”).
Support Services are governed by Christie’s policies and programs described in materials available from Christie. Any supplemental software code
provided to Licensee as part of the Support Services will be considered part of the Software and subject to the terms and conditions of this Agreement.

Warranty and Limitation of Liability

a. No Warranties: The Software is provided “as is” and Christie makes no warranty of any kind with regard to the Software. Christie will not be liable for
errors contained in the Software or in connection with the performance or use of the Software. Christie does not warrant that the Software is free from
any defects or that it will operate uninterrupted. Christie warrants that the media on which the Software is distributed will be free from defects in
materials and workmanship under normal use for a period of ninety (90) days from the date of delivery. Christie will replace any defective media
returned to Christie within the ninety (90) day period. The foregoing is Licensee’s sole and exclusive remedy for breach of the warranty given pursuant
to this Section. Christie does not make any other warranties, either express or implied, including, but not limited to, implied warranties of
merchantability, fitness for a particular purpose, title and non-infringement with regard to the Software.



b. Limitations of Liability: IN NO EVENT WILL CHRISTIE BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES, INCLUDING LOST PROFITS, LOST REVENUES AND LOST DATA ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION,
EVEN IF CHRISTIE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

CHRISTIE SPECIFICALLY DISCLAIMS ANY WARRANTIES OR CONDITIONS, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR
CONDITIONS OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE AND ACCOMPANYING DOCUMENTATION, IF ANY,
PROVIDED HEREUNDER IS PROVIDED “AS IS”. CHRISTIE HAS NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR
MODIFICATIONS.

CHRISTIE FURTHER DISCLAIMS ANY AND ALL REPRESENTATIONS RELATING TO THIRD PARTY SOFTWARE WHICH IS EMBEDDED IN THE SOFTWARE.
Some jurisdictions do not allow exclusions or limitations of certain conditions or warranties. Only those exclusions or limitations that are lawful in
Licensee’s jurisdiction will apply to Licensee and, in such instances, Christie’s liability will be limited only to the maximum extent permitted by law.

Termination

a. Christie may terminate this Agreement at any time and for any reason. Christie may also terminate this Agreement if the Licensee breaches or is in
default of any obligation of Licensee under this Agreement. Upon termination of this Agreement, the Licensee will immediately (i) cease using the
Software and (ii) uninstall the Software from any personal computers, servers or other devices (to the extent it is installed thereon). The Licensee’s
obligation under this provision will survive the termination of this Agreement.

General

a. Notices: Unless otherwise set forth in this Agreement, all notices, or other communications hereunder will be deemed to have been duly given when
made in writing and delivered in person, by courier or deposited in the mail, postage prepaid, and registered mail, return receipt requested, and
addressed to Licensee at the billing address supplied to Christie by Licensee, and addressed to Christie at Christie Digital Systems USA, Inc., c/o Christie
Digital Systems Canada, Inc. at 809 Wellington Street North, Kitchener, Ontario, Canada N2G 4Y7, with a copy (which will not constitute notice) to
Christie’s Legal Department at the same address.

b. Severability and Waiver: Any provision of this Agreement which is held by any court to be unenforceable or invalid will be deemed severed from this
Agreement, without affecting any other provision of this Agreement. No waiver by Christie of any particular default or omission committed by Licensee
will affect or impair the right of Christie in respect of any subsequent default or omission of the same or a different kind. No delay or failure by Christie
to exercise any rights in connection with any default or omission committed by Licensee will affect or impair Christie’s rights in respect of that particular
default or omission or any subsequent default or omission of the same or different kind. In any event, time will continue to be of the essence without the
necessity of specific reinstatement.

c. Governing Law: This Agreement is governed by the laws of the State of California, without regard to its conflict of law principles. Any suit or action
arising out of or in connection with this Agreement will be brought in the federal or state courts located in Orange County, State of California. Each of
Licensor and Licensee hereby irrevocably submit to the jurisdiction of such courts for the purpose of such suit or action and expressly and irrevocably
waive, to the fullest extent permitted by law, any objection it may now or hereafter have to the venue of any such suit or action in any such court and
any such claim that any suit or action has been brought in an inconvenient forum.
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Getting started with
Mystique Install
Understand the requirements and procedures for getting started with Mystique Install.

Mystique Install editions
Learn the differentiating features of the four editions of Mystique Install. Each edition requires a
different license key. For more information, contact your Christie sales representative.

Projector and camera support

Feature Essentials Pro Venue Premium Large Scale
Experience

Channel Up to 12 projectors
(2x3 double stacked)

Unlimited

All channels must be
visible by a single
camera

Unlimited Unlimited

Camera One One Unlimited Unlimited

Screen support

Feature Essentials Pro Venue Premium Large Scale
Experience

Flat Supported Supported Supported Supported

Cylindrical Not supported Supported Supported Supported

Spherical Not supported Not supported Supported Supported

Custom Not supported Not supported Supported Supported

Dual screen Not supported Not supported Not supported Supported

Layout support

Feature Essentials Pro Venue Premium Large Scale
Experience

Wallpaper (Simple) Supported Supported Supported Supported

Wallpaper
(Advanced)

Not supported Supported Supported Supported

 

Christie Mystique Install User Guide 9
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



Feature Essentials Pro Venue Premium Large Scale
Experience

Field of view (FOV) Not supported Not supported Supported Supported

Projector centric Not supported Not supported Not supported Supported

UV Not supported Not supported Not supported Supported

3D Not supported Not supported Not supported Supported

Additional feature support

Feature Essentials Pro Venue Premium Large Scale
Experience

Operate Lite Supported Supported Supported Supported

Black level blending Not supported Available for
purchase.

Contact your Christie
sales representative

Available for
purchase.

Contact your Christie
sales representative

Supported

ACT devices Not supported Not supported Supported Supported

Surface markers Not supported Supported Supported Supported

Pandoras Box
support

Supported Supported Supported Supported

Guardian Available for
purchase.

Contact your Christie
sales representative

Available for
purchase.

Contact your Christie
sales representative

Not supported Not supported

Related information

Requesting an updated license (on page 19)

System recommendations
Understand the hardware and software requirements for Mystique Install.

Computer and software requirements
Learn the hardware and software recommendations for running Mystique Install.

Computer requirements

Minimum Recommended

Intel i5 or compatible processor Intel Core i7-4700 or higher

5GB of free disk space 10GB of free disk space

Getting started with Mystique Install

Christie Mystique Install User Guide 10
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



Minimum Recommended

4GB RAM • 8GB RAM (up to eight HD or four 4K projectors)

• 16GB RAM (up to 24 HD or 12 4K projectors)

• 32GB RAM (up to 48 HD or 24 4K projectors)

A true color (32 bit) display with a minimum resolution
of 1024 x 768

A true color (32 bit) display with a resolution of 1920 x
1080

1 Gbps Ethernet port 1 Gbps Ethernet port

• Microsoft Windows 8 64-bit

If using Microsoft Windows 8.1, install the update
located here: https://support.microsoft.com/en-us/
help/2919355.

• Microsoft Windows 10 64-bit

Microsoft Windows 10 64-bit

Supported software
• Adobe Reader 11 or later

• Twist 2.4.2 or later

Christie recommends that you use Twist Premium with the Essentials and Pro Venue editions of
Mystique Install, and Twist Pro with the Premium and LSE editions of Mystique Install. For more
information about the features of Twist, refer to Christie Twist User Guide (P/N: 020-101380-XX).

Network requirements
Learn the network requirements for Mystique Install.

• Unmanaged Gigabit Ethernet switch (Qty. 1)
Typically, managed switches are compatible with Mystique Install, however they may be
challenging to configure when placed between the control computer and an Ethernet camera.
Christie provides support only for managed networking equipment supplied by Christie.

• Ethernet cable for each network device, such as computers, projectors, and cameras (Qty. 1)

• 1 Power over Ethernet (PoE) injector or a PoE switch (if using a PoE camera)

Camera recommendations
Mystique Install must be used with at least one of the following calibrated cameras provided by
Christie.

The Essentials and Pro Venue editions of Mystique Install only support using a single camera per
configuration.

When mapping a playing surface, for the widest field of view in the camera image Christie recommends
placing the camera as high as possible, for example by the broadcast booth.

• 3.2MP USB3 FLIR Flea 3 USB FL3-U3-32S2M-C (recommended)

• 5.0MP Mono GigE PoE FLIR Blackfly BFLY-PGE-50H5M-C
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To use the Power over Ethernet (PoE) functionality of this camera, a PoE injector or a PoE-
enabled hub or router is required. If the camera cannot be located on the network, use a PoE
injector to connect the camera to the control computer, or connect the camera to a PoE-
enabled hub or router.

• 5.0MP Mono GigE PoE FLIR Blackfly BFLY-PGE-50S5M-C (required for Guardian)

• 5.0MP GigE FLIR Flea 3 FL3-GE-50S5M-C

• 1.2MP USB2 FLIR Chameleon CMLN-13S2M

• 2.0MP GigE FLIR Flea 3 FL3-GE-20S4M-C

FLIR cameras were previously known as Point Grey cameras.

Choosing a camera
If using the Essentials or Pro Venue edition of Mystique Install and the requirements for the projectors
in a configuration are known, use the Mystique Install Camera Calculator tool to select the most
appropriate camera for the configuration.

1. In a browser, navigate to https://www.christiedigital.com/en-us/visual-solutions-case-studies/
tools/mystique-install-camera-calculator.

2. Enter the projection specifications in to the calculator and click Update.
A list of recommended cameras for the configuration is displayed under the projection
specifications.

Supported projectors
Use Mystique Install with at least one of the following supported projectors or with Pandoras Box.

While the Essentials edition of Mystique Install supports a maximum of 2x3 stacked projectors, other
editions of Mystique Install support an unlimited number of projectors.

• M series projectors must have Main Software version 2.3.0 or later installed

• J Series projectors must have Main Software version 1.1.0 or later installed

• D4K series projectors must have Main Software version 1.4 or later installed

• D4KLH series projectors must have Main Software version 1.2.0 or later installed

• Boxer projectors must have Main Software version 1.6 or later installed

• Crimson projectors must have Main Software version 1.1 or later installed

• D4K40-RGB projectors, main software version 1.0.0 or later

• Pandoras Box 6.0 or later
Black level blending is not supported by Pandoras Box. When using Pandoras Box, blend
quality is dependent upon projector support for gamma 2.2.

Product documentation
For installation, setup, and user information, see the product documentation available on the Christie
website. Read all instructions before using or servicing this product.

1. Access the documentation from the Christie website:

• Go to this URL: http://bit.ly/2lNXz54 or
https://www.christiedigital.com/en-us/business/products/mystique.
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• Scan the QR code using a QR code reader app on a smartphone or tablet.

2. On the product page, select the model and switch to the Downloads tab.

Related documentation
Additional information on this product is available in the following documents.

• Mystique Operate Lite Instruction Sheet (P/N: 020-102382-XX)

• Mystique Operate Lite API Commands Guide (P/N: 020-102628-XX)

• Twist User Guide (P/N: 020-101380-XX)

Installing operating system patches
The following patches must be installed on the operating system before installing Mystique Install

Windows 8 64-bit
• https://support.microsoft.com/en-us/help/2919355

• https://www.microsoft.com/en-us/download/details.aspx?id=49082

Windows 8.1 64-bit
• https://support.microsoft.com/en-us/help/2919355/windows-rt-8.1,-windows-8.1,-and-

windows-server-2012-r2-update-april-2014

• https://www.microsoft.com/en-us/download/details.aspx?id=49082

Windows 10 64-bit
• There are no recommended patches at this time.

Installing Mystique Install
To load Mystique Install, complete the following steps.

If a restart prompt appears before the installation is complete, select No.

1. Ensure all operating system patches are installed.

2. If there is an existing AutoCal or Mystique Install installation on the computer, Christie
recommends uninstalling the application prior to loading the latest version of Mystique Install,
unless the older installation is required for compatibility with older hardware.
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If an existing AutoCal or Mystique Install installation is uninstalled after loading the latest
version of Mystique Install, Mystique Install may need to be removed and reinstalled to
correctly restore all drivers and dependencies.

3. Insert the Christie installation media in to the USB drive on the computer.
If the installation does not start automatically, click Start > Computer. Browse to the
Mystique Install installation media, and double-click the MystiqueInstallSetup.exe file that
corresponds to the installed version of Windows.

4. To install Mystique Operate Lite at the same time as Mystique Install, follow these steps:
Mystique Operate Lite can also be installed at a later date.
a) Verify that port 80 is not in use on the computer.

b) Select Optional Software.

c) Select Install Mystique Operate Lite and click OK.

5. Click Next.

6. To proceed with the Mystique Install installation, click Next.

7. Select I accept the terms in the License Agreement and click Next.

8. Select whether the installed software will participate in the User Experience Improvement
Program, and click Next.

9. Click Install.

10. Click Finish.
The Mystique Install installation is complete.

11. In the Mystique Operate Lite installation dialog, click Next.

12. Select I accept the terms in the License Agreement and click Next.

13. Click Finish.
The Mystique Operate Lite installation is complete.

14. When the installation is complete, restart the computer.

Related information

Installing operating system patches (on page 13)
Ensuring port 80 is not in use (on page 14)

Ensuring port 80 is not in use
Mystique Operate Lite installs a web server on port 80. Verify that no other programs are using port
80 before you install Mystique Operate Lite.

There are two known services that might use port 80—the World Wide Web Publishing Service, and
the Web Deployment Agent Service. If either service is running on your system, stop the service and
change the startup type of the service to Manual before you install Mystique Operate Lite.

1. On your computer, click Start > Control Panel > Administrative Tools > Services.

2. Locate the World Wide Web Publishing Service.

3. Right-click the service and then click Properties.

4. In the Startup type list, select Manual.

5. In the Service status area, click Stop.

6. Click Apply.
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7. Repeat steps two to six for the Web Deployment Agent Service.

Related information

Installing Mystique Install (on page 13)

Installing Mystique Operate Lite
Mystique Operate Lite provides remote management of Mystique Install.

For more information about Mystique Operate Lite, visit www.christiedigital.com.

1. Browse to C:\Program Files\Christie Digital Systems\Mystique Install 2.1\Mystique
Operate.

2. To run the installer, double-click MystiqueOperate.msi.

3. In the Mystique Operate Lite installation dialog, click Next.

4. Select I accept the terms in the License Agreement and click Next.

5. Click Finish.
The Mystique Operate Lite installation is complete.

Connecting the control computer to a projector
and a camera
A minimum of one camera and one Mystique Install-enabled projector must be connected to the
control computer.

1. Connect a computer to a network switch with an Ethernet cable.
A wireless connection is not recommended with network (GigE) cameras.

2. Connect an Ethernet cable from each projector to the network switch.
Each projector requires a unique IP address and must be added to the same network subnet as
the control computer. For more information, refer to the projector documentation.

3. Connect the camera to the control computer over Ethernet or with a USB connection.

• Ethernet—Connect the camera and the control computer to an unmanaged switch.
If a camera is connected to the control computer with an Ethernet connection it must have
a valid IP address and be accessible on the local network.
Do not connect network cameras to a managed switch. Camera drivers are loaded by the
Mystique Install Setup Wizard.

• USB connection—Use the cable supplied with the camera or a high quality equivalent.
Cameras connected with a USB connection are typically connected directly to the control
computer, but a high quality USB hub or repeater can also be used. To determine what
extenders or hubs are supported, see the camera supplier website.
Flea3 GigE cameras come with a power supply that must be connected, while other
camera models receive power through a USB or a POE connection. If a Qalif camera is
being used, verify it is operating in Remote mode.
Typically, cameras work correctly with Mystique Install without modifying their settings. If
you need to modify camera settings, see the documentation provided by the camera
manufacturer or visit their website. Software tools provided by the camera manufacturer
are installed in Start > Mystique Install.
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Camera drivers are loaded by the Mystique Install Setup Wizard.

Workflows
Understand the different ways of creating and calibrating a Mystique Install configuration.
2D configurations:

• Smooth screen layout (on page 16)—Displays content on a smooth screen or surface in
2D.

3D configurations:

• Manual calibration (on page 18)—Requires an operator to manually identify
correspondences between model features in the CAD model and the same features as seen
through each camera.

• ACT calibration (on page 17)—Performs a 3D calibration using an ACT device.

• Structured light calibration (on page 16)—Requires minimal manipulation of known
calibration data to align the model and camera.

Smooth screen configuration workflows for 2D layouts
When creating a configuration for a flat or cylindrical screen, perform these steps.

1. Add the projectors throwing light onto the surface (on page 23).

2. Add the cameras that can view the projection surface (on page 27).

3. Define the screen space (on page 36).

4. Calibrate the cameras (on page 30).

5. Set the type of layout and the projector orientation (on page 39).

6. Run a full system calibration on the configuration (on page 45).

7. Create or adjust any blends or warps on the projected image (on page 49).

Playing surface configuration workflows
When creating a configuration for a flat or cylindrical screen, perform these steps.

1. Add the projectors throwing light onto the surface (on page 23) or connect a Pandoras Box
Manager as a projector (on page 25).

2. Add the cameras that can view the projection surface (on page 27).

3. Define the screen space (on page 36).

4. Map the markers points on the playing surface (on page 76).

5. Calibrate the cameras (on page 30).

6. Run a full system calibration on the configuration (on page 45).

Structured light calibration workflow for 3D layouts
Create a 3D layout by aligning the point cloud provided with the 3D model and the point cloud
generated by Mystique Install.

1. Add the projectors throwing light onto the surface (on page 23).
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2. Switch to the Projector Control tab.

3. To enhance the contrast on the projection surface, making the edges and features more visible
to the cameras, select a projector and set it to use a combination of black and gray test
patterns.

4. Switch to the Install tab.

5. Add the cameras that can view the projection surface (on page 27).

6. (Optional) Manually set the exposure for the cameras (on page 55).

7. Select the 3D model (on page 56).

8. Expand the Calibration pane, and select Structured Light.

9. Configure the Structured Light settings (on page 57).

10. Gather the information about the scene through test patterns and projector associations (on
page 57).

11. Click Baseline Camera Calibration.

12. Generate a point cloud of the scene from the projector and camera associations and the
calibrations (on page 58).

13. If the point cloud has data that is not relevant to the model, remove all unnecessary points (on
page 58).

14. Align the point cloud with the model.
a) To change the angle of the viewport contents, right-click and adjust the orientation of the

point cloud.

b) Click Reorient Point Cloud.

c) Click and drag three points of the camera point cloud onto the corresponding locations on
the model.

15. Align the generated point cloud with the model point cloud data. (on page 59)

16. Evaluate how closely the scene point cloud matches the model point cloud.
The two point clouds must overlap exactly. If the matching does not appear to be exact, repeat
steps 13 to 16.

17. Determine the position of the projectors (on page 59).

18. To verify the layout is correct, draw a test pattern on the model (on page 60).
If the layout must be corrected, repeat steps 13 to 18.

19. Blend the content areas for all projectors in the configuration (on page 60).

20. To transfer the projector and camera location information to the content system, export the
calibration file.

ACT calibration workflow for 3D layouts
Perform a 3D calibration using an ACT device.

1. Add the projectors throwing light onto the surface (on page 23).

2. Switch to the Projector Control tab.

3. To enhance the contrast on the projection surface, making the edges and features more visible
to the cameras, set the projectors to use a combination of black and grey test patterns.

4. Add the cameras that can view the projection surface (on page 27).
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5. (Optional) Manually set the exposure for the cameras (on page 55).

6. Select the 3D model (on page 56).

7. Calibrate the cameras using an ACT device (on page 31).

8. Gather the information about the scene through test patterns and projector associations (on
page 57).

9. Create a point cloud of the scene from the projector and camera associations and the
calibrations (on page 58).

10. If the point cloud has data that is not relevant to the model, remove all unnecessary points (on
page 58).

11. Align the generated point cloud with the model point cloud data. (on page 59)

12. Evaluate how closely the scene point cloud matches the model point cloud.
The two point clouds must overlap exactly. If the matching does not appear to be exact, repeat
steps 11 to 13.

13. Determine the position of the projectors (on page 59).

14. To verify the layout is correct, draw a test pattern on the model (on page 60).
If the layout must be corrected, repeat steps 11 to 15.

15. Blend the content areas for all projectors in the configuration (on page 60).

16. To transfer the projector and camera location information to the content system, export the
calibration file.

Related information

Automatically calibrating the camera using a Christie ACT device (on page 31)

Manual calibration workflow for 3D layouts
Manual Calibration relies on an operator finding correspondences between model features in the CAD
model and the features seen through the cameras. For each correspondence, the feature must be
visible by a minimum of two cameras. Six correspondences are required per camera.

Prior to each subsequent alignment, ensure that the correspondences align with the marked features.

1. Add the projectors throwing light onto the surface (on page 23).

2. Switch to the Projector Control tab.

3. To enhance the contrast on the projection surface, making the edges and features more visible
to the cameras, set the projectors to use a combination of black and grey test patterns.

4. Add the cameras that can view the projection surface (on page 27).

5. (Optional) Manually set the exposure for the cameras (on page 55).

6. Select the 3D model (on page 56).

7. Manually calibrate the cameras (on page 56).

8. Gather the information about the scene through test patterns and projector associations (on
page 57).

9. Create a point cloud of the scene from the projector and camera associations and the
calibrations (on page 58).

10. If the point cloud has data that is not relevant to the model, remove all unnecessary points (on
page 58).
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11. Align the generated point cloud with the model point cloud data. (on page 59)

12. Evaluate how closely the scene point cloud matches the model point cloud.
The two point clouds must overlap exactly. If the matching does not appear to be exact, repeat
steps 11 to 13.

13. Determine the position of the projectors (on page 59).

14. To verify the layout is correct, draw a test pattern on the model (on page 60).
If the layout must be corrected, repeat steps 11 to 15.

15. Blend the content areas for all projectors in the configuration (on page 60).

16. To transfer the projector and camera location information to the content system, export the
calibration file.

Creating a Mystique Install configuration
After the installation is complete, open Mystique Install and create a configuration.

1. On your computer, click Start > All Programs > Christie > Mystique Install 2.1.

2. To create a new configuration, do one of the following.

• If the environment uses a flat or cylindrical screen and has a basic layout, to complete a
quick configuration setup, click Smooth Screen Guided Setup.

• To display content on a smooth screen or surface in 2D, click New Smooth Screen
Layout.

• To projection map a multidimensional scene, click New 3D Layout.

Opening an existing configuration
To load a saved configuration file, complete the following steps.

1. In Mystique Install, click Open.

2. Browse to the location of the configuration file (*.cal).

3. Select the file and click Open.

Licensing Mystique Install
Mystique Install requires a license dongle and valid license to identify the available features within the
software. If the license dongle is lost or altered, Mystique Install will not function.

Requesting an updated license
To add features to the Mystique Install license or to change the product tier, a new license file must be
requested.

1. Connect the Mystique Install license dongle to the computer where Mystique Install is installed.

2. Select License Details.

3. Click Upgrade.

4. Click Request Upgrade.
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The .DAT file with the required information is copied to the license dongle.
Alternatively, to create a .DAT file, press CTRL+SHIFT+Q.

5. To close all License dialogs, click Close.

6. Navigate to the contents of the license dongle, and copy the .DAT file into an email.

7. In the email with the .DAT file, identify the license tier to upgrade to.

8. Send the license request to Christie Customer Service at orders@christiedigital.com.
After the license upgrade has been approved, a new license key will be returned through email.

9. When the updated license is received, apply the new license to Mystique Install.

Related information

Applying a new Mystique Install license (on page 20)
Mystique Install editions (on page 9)
Technical support (on page 22)

Applying a new Mystique Install license
After receiving an updated license file, apply the license to Mystique Install.

1. When the email containing the updated license is received, copy the .KEY file from the email to
the license dongle.
The .KEY file must be on the original Christie license dongle for the upgrade to complete
successfully.

2. Connect the Mystique Install license dongle to the computer where Mystique Install is installed.

3. Right-click the Mystique Install shortcut and select Run as Administrator.
Mystique Install reads the files on the license dongle, and automatically detects an upgraded
license file.

4. In the Upgrade License dialog, to apply the new license file click Continue Upgrade.

5. After the upgraded license is applied to Mystique Install, in the confirmation dialog click Close.

Related information

Requesting an updated license (on page 19)

Uninstalling Mystique Install
Remove Mystique Install using the Windows Control Panel.

Bonjour, Microsoft Visual C++ 2010, 2012, and 2015 Redistributables, and Microsoft .NET Framework
4 may be in use by other programs and are not uninstalled by the wizard.

1. On a Windows 8 computer, select Start > Control Panel > Programs and Features.
On a Windows 10 computer, select Settings > Apps & features.

2. Right-click Christie Mystique Install and click Uninstall.

3. Click Yes.
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Keyboard shortcuts
Learn keyboard shortcuts for Mystique Install.

General shortcuts

Action Shortcut

Launch Guided Setup CTRL+G
Create a new .cal file CTRL+N
Open an existing .cal file CTRL+O
Save changes to a .cal file CTRL+S
Save a .cal file as CTRL+SHIFT+S
Run a calibration CTRL+R
Show the log viewer. CTRL+SHIFT+V

System View and Screen Marker shortcuts

Action Shortcut

View a single window ALT+1
View two vertical windows ALT+2
View two horizontal windows ALT+3
View four windows ALT+4
Zoom in on the viewport Scroll wheel on mouse
Zoom in on area around the mouse pointer in Camera
or System view

CTRL

Add a marker on the model ALT+Left click
Move a marker point on the model ALT+Left click and drag
Increase or decrease a marker point size in System
view

ALT + Scroll wheel on mouse

Move the viewport on the X or Z axes Left click and drag
Rotate the viewport on the X or Z axes Right click and drag
Move the viewport on the Y axis Center mouse button

Side panel navigation shortcuts

Action Shortcut

Open the Projector pane ALT+P
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Action Shortcut

Open the Camera pane ALT+C
Open the Calibration pane ALT+L
Open the Options pane ALT+O

Smooth screen layout shortcuts

Action Shortcut

Open the Screen pane ALT+S
Open the Layout pane ALT+A
Open the Black Level Blending pane ALT+B

3D layout shortcuts

Action Shortcut

Open the Model pane ALT+M
Open the Projector Camera Associations pane ALT+S
Move the measured point cloud on the X and Z axes SHIFT + Left mouse button
Rotate the measured point cloud on the X and Z axes SHIFT + Right mouse button
Move the measured point cloud on the Y axis SHIFT + Center mouse button

Diagnostics

Action Shortcut

Open a diagnostics folder for the current session CTRL+SHIFT+D
Open a diagnostics folder for the current session in the
images directory

CTRL+SHIFT+I

Open a diagnostics folder for the current session in the
log directory

CTRL+SHIFT+L

Technical support
Technical support for Christie products is available at:

• North and South America: +1-800-221-8025 or Support.Americas@christiedigital.com

• Europe, Middle East, and Africa: +44 (0) 1189 778111 or Support.EMEA@christiedigital.com

• Asia Pacific: +65 6877-8737 or Support.APAC@christiedigital.com
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Managing projectors
To manage all of the connected projectors, use the Projector Control tab.

Searching for a projector
Search by port number when adding a projector to the configuration.

The projector must be on the same subnet as the computer when searching by port number.

1. In the left pane, click Projector.

2. Click Add.

3. Click Search.

4. Select a projector.

5. Click OK.

Manually adding a projector to a configuration
If a projector is not automatically detected, or if it is not on the same subnet as other projectors in a
configuration, you can manually add the projector to the configuration by entering the projector IP
address and port number.

To manually add a projector to a configuration, you must know the IP address and port number of the
projector. To find the IP address of a projector, refer to the projector documentation.

1. In the left pane, click Projector.

2. Click Add.

3. On the Manual tab, type the IP Address and Port number of a projector.

4. Click Search.

5. Select the projector.

6. Click OK.

Removing a projector from a configuration
To remove a projector that is no longer used in a configuration, complete the following steps.

1. Open a configuration file.

2. In the left pane, click Projector.

3. Select a projector and click Remove.
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Identifying projectors in a configuration
Use the identify feature to display the Channel ID of each projector on the projection surface.

1. Switch to the Projector Control tab.

2. Click Identify Projectors.
The Channel ID of each projector in the configuration is displayed on the projection surface.

Reordering the projectors in a configuration
To organize the projectors in a way that is logical for the scene, change the order of the projectors in a
configuration.

1. Open a configuration file.

2. In the left pane, click Projector.

3. Select a projector and click Move Up or Move Down.

Finding projector details
Follow these steps to find the address, software version, and model of a projector.

1. Open a configuration file.

2. In the left pane, click Projector.

3. Select a projector.

4. Expand the Details area.

Customizing default projector options
Customize the default options for projectors added to the configuration.

1. In the left pane, click Options.

2. At the bottom of the pane, expand the Projector area.

3. To manually adjust the settings, clear the Automatic checkbox.

4. To set the size (in pixels) of the grid points that Mystique Install draws during calibration, in
the Grid Box Size field, select a size.

5. To set the spacing of the grid points that Mystique Install uses during calibration, in the
Spacing field, make a selection.
This value is a multiplier of the grid box size.

Controlling a projector
With Mystique Install, commands can be sent directly to a projector from the computer.

If there are multiple projectors in the configuration, some projector controls such as power, test
patterns, and opening or closing the shutter, can be performed on multiple projectors at once.
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1. Switch to the Projector Control tab.

2. In the left pane, click Projector.

3. Select a projector, and do any of the following:

• To turn the projector on or off, in the Power view, click On or Off.

• To open or close the shutter on the projector, in the Shutter view, click Open or Close.

• To change the input source, the test pattern, the warp or the blend, in the Projector view,
click Input, Test Pattern, Warp, or Blend. In the list, make your modification.

• To display or hide markers on the screen, in the Markers view, click Show or Hide.

• To enable other tools, such as a virtual remote, in the Tools view click a selection.

Connecting a Pandoras Box Manager as a
projector
Learn how to add a Pandoras Box Manager as a projector in Mystique Install.

When connecting to a Pandoras Box Manager, each output in a Pandoras Box project appears as a
projector in Mystique Install. While Mystique Install can connect to one Pandoras Box Manager at a
time, multiple Pandoras Box Clients can be connected to a single Manager.
Mystique Install, the Pandoras Box Manager, and all Pandoras Box Clients must be configured for, and
run on, the same network.
If the configuration uses 4K projectors, to have the entire display as a single camera and a single
output in the Pandoras Box Manager change the graphics card settings on the computer to Mosaic or
Surround mode. Then, in Mystique Install, connect to the Pandoras Box Manager.
For a blend for Pandoras Box to appear as expected, Christie recommends using projectors that can
support a gamma curve of 2.2, such as Christie 3-chip DLP projectors. Otherwise, blend quality can
vary.

1. In Pandoras Box Manager, verify that the project file containing the content is open.

2. In Mystique Install, in the left pane, click Projector.

3. Click Add.

4. Do one of the following.

• If the Pandoras Box Manager is installed on the computer used to run Mystique Install,
from the Search Results list, select PB Devices.

• If the Pandoras Box Manager is installed on another computer, or PB Devices does not
appear in the Search Results list, switch to the Manual tab. Type the IP address of the
Pandoras Box Manager, and click Search or Clear & Search.

5. Click OK.

Once you connect to a Pandoras Box Manager, canvases for warping, blending, and test patterns are
created in the Pandoras Box project. Establishing a consistent communication stream might take
longer than expected.
When Mystique Install is run, warps and blends are added to the output and activated in Pandoras Box
Manager.
Some projector controls, such as power and shutter controls, are unavailable when connected to a
Pandoras Box Manager.
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Changing the order of channels in a
configuration
Each projector in a configuration is assigned to a channel. The order of the channels is the order in
which Mystique Install processes events impacting projectors in a configuration.

1. In the left pane, click Projector.

2. Select a channel.
The Channel ID for the projector appears in the far left column of the Projector tab.

3. Click Move Up or Move Down.

Renaming a channel
Change the name of a channel that is used in a configuration.

1. Open a configuration file.

2. In the Projector pane, double-click a projector name.

3. Type a new name.

Swapping channels
Depending on the layout that is defined, swap data between projectors in a configuration.

1. In the left pane, click Layout.

2. In the Type list, select an option.
Data between projectors can be swapped in any of the following layouts:

• Wallpaper (Advanced)

• Fields of View

• Fields of View (Collimated)

• Projector Centric

• Custom Planar

3. In the Channel Extents table, select two full rows.

4. To swap data between the two projectors, click Swap. 
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Configuring cameras
Learn how to locate cameras, add them to the configuration, and change camera settings such as
exposure and binarization.

Adding a camera to a configuration
To add a camera to a configuration, complete the following steps.

The Essentials and Pro Venue editions of Mystique Install only support using a single camera per
configuration.

1. Open or create a configuration file.

2. In the left pane, click Camera.

3. Click Add.

4. Select the camera(s).

• To select one camera, click a camera.

• To select more than one camera, press and hold CTRL and select the cameras.

• To select all of the cameras, click Select All.

• To clear your selection, click Select None.

5. To see a recently connected camera, click Refresh.

6. Click OK.
When a camera is added, a preview of the camera image appears in the Camera View.

Related information

Creating a Mystique Install configuration (on page 19)
Opening an existing configuration (on page 19)

Finding camera details
To find details about the camera and network information, complete the following steps.

1. Open a configuration file.

2. In the left pane, click Camera.

3. Select a camera.

4. Expand the Details area.
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Adding a camera profile
Camera profiles are stored on a camera and they define the technical characteristics of a camera and
its lens.

If a separate camera profile is provided by Christie, complete the following steps to add the profile to
Mystique Install.

1. Click File > Manage.

2. Click Add.

3. In the Open File dialog, browse to the .xml file that contains the camera profile.

4. Select the .xml file and click Open.

5. Click OK.

Setting up the camera image
Before you adjust the digital settings for a camera, ensure that the camera is in focus and that the
lens aperture is appropriately set.
Binarization defines the threshold of the black (dark) and white (bright) pixels of a captured image. By
default, Mystique Install automatically determines the binarization threshold values. An ideal
binarization occurs when the background noise of an image is minimized and all grid points are fully
captured. If required, to manually change camera settings, such as exposure and binarization, use the
Camera menu in the left pane.

Original binarization Correct binarization

Binarization threshold too low Binarization threshold too high
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When a binarized image is taken, projectors in the system display a black background with a white
grid. If Camera Markers is selected, the on-screen markers used for camera calibration are turned on.
The correct binarization and exposure values are assigned by detecting these markers.
If a single camera and projector are activated, you can adjust the binarization threshold and camera
exposure of the camera.

Adjusting camera exposure and binarization
Select how to adjust the camera exposure and binarization.

By default, Mystique Install automatically determines exposure and binarization settings. Before
making changes to these settings, verify that:

• The screen is defined.

• The required cameras are imported and activated.

• The required channels are imported and activated.

• The channel extents are defined.

• All points are mapped.

If you are using multiple cameras in a configuration, the binarization and exposure settings for each
camera must be adjusted individually.

1. Connect at least one camera and select at least one channel.

2. In the left pane, click Camera.

3. Expand the Exposure & Binarization area.

4. In the list, select one of the following options:

• Automatic—Automatically adjust exposure and binarization based on the lighting
conditions of the scene. This setting is recommended for use if lighting conditions cannot
be controlled, for example, an outdoor space.

• High Contrast—Automatically adjust exposure and binarization using additional inverse
test patterns recorded by the system. This setting can improve image processing and
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contrast and is recommended for use if ambient light levels are low, or lighting conditions
are not manually controlled.

• Manual—Manually configure unique exposure and binarization settings. This setting is
recommended for use if lighting conditions remain consistent between calibration runs.

Manually adjusting exposure and binarization
If necessary, manually adjust the exposure and binarization settings.

Binarization evaluates the image projected on the screen and converts the image to black and white,
without any gray. This conversion occurs when all ambient light is filtered out and the image displays
only the grid points in their sharpest context.
When making an adjustment, find a balance between the correct exposure and binarization threshold.
If there are multiple cameras in a configuration, the binarization and exposure settings must be
adjusted for each individual camera.

1. Connect at least one camera and select at least one channel.

2. In the left pane, click Camera.

3. Expand the Exposure & Binarization area.

4. In the list, select Manual.

5. To change the projector grid settings, or to change the camera calibration marker settings, in
the Marker Type list, select Projector Dots or Screen Markers.

6. To adjust the brightness of the camera image, drag the Gain slider back and forth or click the
- and + buttons.

7. To adjust how long the camera shutter stays up when capturing images, drag the Exposure
slider back and forth or click the - and + buttons.
Christie recommends adjusting the exposure until the brightest projected square is almost
pure white.

8. Select a binarization threshold that makes the projected pattern as clear as possible.
a) Click Thresholding Mode.

b) Drag the Thresholding slider back and forth or click the - and + buttons until the image
reaches an optimal threshold.

Adjusting the threshold changes the image so anything above the threshold is white, and
anything below the threshold is black. Try to avoid losing points when adjusting the
binarization.

Calibrating cameras
To map content correctly, Mystique Install must know where the screen, playing surface, or object is
located in the camera image.
When the Calibration menu is opened in the left pane, two display windows appear. On the left, the
Camera View displays a real-time picture. On the right, the System View displays a representation of
the configuration. To display, hide, or reorder windows, you can select one of the options in the upper-
right hand corner of the screen.
Depending on the complexity of the configuration, choose from one of the following methods for
camera calibration.

• ACT—If the configuration is complex, or if using a multiple camera system, Christie
recommends using an ACT device to perform an automatic camera calibration using known
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features of a surface or LED markers at known 3D points. This method allows cameras to be
automatically calibrated by toggling the LED markers on and off in a pattern.

• Image-Based—When mapping an arena surface that has painted markers on it, or if the
screen is flat, Christie recommends performing an automatic camera calibration using features
that appear on the surface itself. After performing an initial calibration, this mode can
automatically recalibrate the camera if it is bumped or moved. This method is intended for use
with a single camera.

• Manual—If the screen is flat or cylindrical, and the configuration uses a single camera,
Christie recommends performing a manual calibration using the corners and edges of a screen.

Related information

Automatically calibrating the camera using a Christie ACT device (on page 31)
Performing an image-based calibration (on page 31)
Manually calibrating the camera (on page 32)

Automatically calibrating the camera using a Christie ACT
device
Use a Christie ACT device to control the visible markers of a connected camera. This feature is not
supported by the Essentials edition of Mystique Install.

A camera can only be calibrated using a Christie ACT device if the size of the screen is determined
manually.

1. Open or create a configuration file.

2. In the left pane, click Calibration.

3. Select a camera.

4. Select ACT from the list.

5. To add a Christie ACT device to a configuration manually, click Add then type the IP address of
the device.

6. Do any of the following:

• To receive a prompt before running the automatic camera calibration, select Prompt for
Calibration.

• If a threshold value that works for all ACT points cannot be obtained, to split a camera
image in to zones and automatically threshold each zone individually, select Threshold by
Zone.

7. To run an automatic camera calibration, click Calibrate Cameras.

8. To remove a Christie ACT device from a configuration, select the device and click Remove.

Performing an image-based calibration
An image-basaed calibration may be performed if the screen size is determined using an image.

Christie recommends only performing image-based calibrations in settings where lighting conditions
are consistent. If lighting conditions change between calibrations, manual camera calibration might be
required.
After calibrating the camera, take a new reference image so that if the camera is unintentionally
moved out of position, it can automatically be recalibrated to align with the new reference image.
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1. Open or create a configuration file.

2. In the left pane, click Calibration.

3. Select a camera.

4. Select Image-Based from the list.

5. If required, do any of the following.

• To set the camera exposure manually, clear the Enable Auto Exposure checkbox, and
move the slider.

• When mapping a playing surface, to mask moveable features visible to the camera that
are outside of the screen and not covered by the marked surface overlay, such as non-
fixed seating or advertising, select Use Screen as Mask. This option is available only with
the Pro Venue edition of Mystique Install.

6. Click Calibrate Cameras.

7. To take a new reference image, click Take Reference Image.

Recalibrating the camera to a reference image
When a camera is accidentally moved out of place, use a reference image to recalibrate the camera.

To recalibrate a camera using this method, a reference image of the configuration must have been
previously taken using Mystique Install.
Christie recommends this method of recalibration when correcting for small motions of a fixed camera,
such as a building vibration. If the camera is moved to a new location or its view is significantly
altered, manually realign the camera for the new configuration and take a new reference image.

1. Open a configuration file.

2. In the left pane, click Calibration.

3. Select a camera.

4. Select Image-Based from the list.

5. To recalibrate the camera, click Calibrate Cameras.

Manually calibrating the camera
Map the 3D and 2D points for each camera in a configuration.

1. Switch to the View tab.

2. In the System View area, click Points.

3. Click a 3D point.
The point turns yellow.

4. To move a 3D point, change the values in the coordinate fields.

5. Select one of the following coordinate systems :

• Cartesian—Base the position of the screen markers by X, Y, and Z coordinates. This is the
default coordinate system.

• Cylindrical—Base the position of the screen markers upon the Radius (the distance
between the screen marker and the Z-axis), the Yaw (the angle of the screen marker
about the Z-axis, and the Z (the height of the screen marker above the XY plane).
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• Spherical—Base the position of the screen markers upon the Radius (the distance
between the screen marker and the origin), the Yaw (the angle of the screen marker about
the Z-axis), and the Pitch (the angle of the screen marker from the horizontal plane).

6. To move the corresponding 2D point in the Camera View, in the Camera View list, select a
camera.

7. Select and drag the 2D point or change its values in the marker table.

8. Repeat steps 6 and 7 for each 2D point that requires mapping.

9. Click Save.

Adding 3D points to the System View
If the screen size must be determined manually, add 3D points to the System View. If the screen size
is determined automatically or by importing an image file, the points are added automatically.

To calibrate the camera, there must be a minimum of six points or, if they are coplanar, four points.
If you are working with a multiple camera installation, Christie recommends that each pair of
overlapping cameras share four points. The points should be distributed outward to the corners of the
overlap area. If you follow this recommendation, the number of points required for a two camera
installation is eight, and six are seen by each camera.
When adding points automatically, Mystique Install removes any existing points and adds a new grid
of points.

1. Switch to the View tab.

2. In the System View area, click Points.

3. In the Screen Markers window, click 3D Points .

4. Select the number of horizontal and vertical points.

5. Click OK.

6. To adjust the position of a point, in the Screen Markers window, select the point and adjust the
X, Y, and Z values.

7. To manually add a point, in the Screen Markers window, click Add .

8. To delete a point, in the System View window, select a point and in the Screen Markers area,
click Delete.

Locating the corners of a screen
When using a single camera system and the Wallpaper (Simple) layout, Mystique Install can
automatically locate the corners of a screen that correspond to the corners that are defined in the
System View.

Before locating the corners of a screen, Christie recommends verifying the following:

• The screen has a well-defined border with a high degree of contrast between the screen area
and the border.

• There are no objects between the camera and the screen that could obscure the view of the
camera.

• The camera aperture is set so that the image is visible, but not over exposed.

• The camera focus is adjusted to provide a clear, sharp image.

• The center of the Camera View is in the center of the screen.
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• The entire screen is visible to the camera.

This feature is best suited for use with planar rectangular screens.

1. Switch to the Home tab.

2. In the Tools area, click Find Corners.
In the Camera View window, after Mystique Install searches for corners, blue dots appear in
the corners of the screen and blue lines appear along the edge of the screen.
If a Cylindrical option is selected, to represent the curved edges of the screen, the blue circles
appear on the top and bottom of the screen area.

3. If necessary, adjust the corner points to match the corner of the screen.

4. To add 2D calibration points, select the points with the mouse and then drag them from the
System View to the Camera View.

5. If necessary, manually adjust the corner points.
a) Click and drag the blue circle.

When you click or drag a circle, the circle becomes yellow and hollow.

b) Drag all four circles to their desired locations.

c) For fine adjustments to corner locations, press and hold the CTRL key.
A zoom window appears.

d) Move the circles as required.
To move a selected circle by 10 pixels, press CTRL + the arrow keys.
To move a circle by one pixel, press CTRL + SHIFT + the arrow keys.

e) To close the zoom window, release the CTRL key.

Adjusting the Camera View
To see what is currently visible to the cameras in a configuration, use Camera View.

1. Switch to the View tab.

2. In the Camera Views pane, select any of the following options:

• Calibration Points—Show the calibration points around the edges of the screen.
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• Channels—Show the projector display area on the screen for the current configuration.

• Screen—Show the screen outline.

• Screen Grid—Display a grid on the screen that shows the interior shape of the screen (as
a blue grid).

• Projectors—Show the area that a projector can cover.
To confirm that overlays are present outside of the screen boundary, Christie recommends
using the RANSAC fit solver when selecting projectors.

• Mappers—Show where projector mappers are detected and the margin of error detected
between cameras.

• Features—Show matched features on the projection surface after you take a reference
image.

Adjusting an image in Camera View
Make adjustments to images in Camera View using the mouse or the icons that appear at the top of
the window.

1. Switch to the Camera View.

2. To make adjustments to an image, do any of the following:

• To change the position of an image, click the left mouse button and drag an image.

• To zoom in or out on an image, use the wheel button on the mouse or, at the top-left of
the window click Zoom In or Zoom Out.

• To fit the current image to the Camera View window, at the top-left of the window, click
Fit.

• To pause the real-time view from the camera, in the top-left of the window, click Pause.

• To change the opacity of an image that appears over the camera view, in the top-left of
the window, move the Opacity slider left or right.

• To add a high-pass filter to the screen or object in order to view its edges, in the top-right
of the window, move the Sharpness slider left or right.

• To capture a camera reference image and carry forward any marker points specified, in the
left pane, click Calibration. Select Image-Based and click Take Reference Image.

Removing a camera from a configuration
To remove a camera from a configuration, complete the following steps.

1. Open or create a configuration file.

2. In the left pane, click Camera.

3. Select a camera and then click Remove.

Configuring cameras
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Managing the image
position and layout
To manipulate a display image, set up screen definitions and define the layout of the screen.

Setting up screen definitions
Learn how to set up the geometry definitions that define the characteristics of the physical projection
surface.

Configuring a flat screen or a marked surface
To configure a flat screen, or to map a playing surface, complete the following steps.

1. In the left pane, click Screen.

2. In the Shape list, select Flat.

3. In the Determine Size list, select one of the following screen parameters:

• Automatically—Determine the screen or marked surface width and height using the
camera calibration markers.

• Manually—When installing more than one camera, or manually specifying the width and
height, use this option and in the Scene Units list, select a unit of measurement.

• From Image—If you are mapping a playing surface, import a .png file of a marked
surface. This option is only available with the Pro Venue edition of Mystique Install or
higher.

Automatically setting up a cylindrical screen
With Mystique Install, the dimensions of a cylindrical screen can automatically be defined.

1. In the left pane, click Screen.

2. In the Shape list, select Cylinder.

3. In the Determine Size list, select Automatically.

4. To adjust the top and bottom radii independently, clear the Lock Radius checkbox.

Manually setting up a cylindrical screen
If more than one camera is installed in a configuration, the dimensions of the screen must be
manually defined.

1. In the left pane, click Screen.

2. In the Shape list, select Cylinder.
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3. In the Determine Size list, select Manually.

4. In the Scene Units list, select a unit of measurement.

5. Specify the screen Radius.

6. Specify the Height of the screen.

7. To define the minimum horizontal angle measured from the center of the screen to the left
side, type a Min. Angle value.

8. To define the maximum horizontal angle measured from the center of the screen to the right
side, type a Max. Angle value.

Setting up a spherical screen
When setting up a spherical screen, the radius, vertical angles, and horizontal angles of the screen
must be defined.

1. In the left pane, click Screen.

2. In the Shape list, select Sphere.

3. In the Scene Units list, select a unit of measurement.

4. Specify the screen Radius.

5. To define the minimum horizontal angle measured from the center of the screen to the left
side, type a Min. H. Angle value.

6. To define the maximum horizontal angle measured from the center of the screen to the right
side, type a Max. H. Angle value.

7. To define the minimum vertical angle measured from the center of the screen to the bottom,
type a Min. V. Angle value.

8. To define the maximum vertical angle measured from the center of the screen to the top, type
a Max. V. Angle value.

Configuring a custom screen
Define custom screen shapes with Mystique Install.

When using this option with a wallpaper, projector centric, or custom planar layout, ensure that the
screen is parameterized with UV texture mapping coordinates.

1. In the left pane, click Screen.

2. In the Shape list, select Custom.

3. In the Screen File Units list, select a unit of measurement.

4. In the Content Screen field, navigate to an .obj or a .wrl file.

5. Select a file and click Open.

Using a laser scan file to set up a screen
If the content screen designed using Mystique does not align with the projection surface in the real
world, scan or map the projection surface and import the file into Mystique Install as an .obj file.

Before importing a laser scan file into Mystique Install, the following tasks must be complete.

• A content screen (.cal) file must be saved to the computer.
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• The content screen file must be correctly parametrized.

• A laser scan file must be saved to the computer.

• The selected layout in Mystique Install must be Projector Centric.

When the Projector Centric layout is selected, channel extent previews use approximate values.

1. In the left pane, click Screen.

2. In the Shape list, select Custom.

3. In the Content Screen field, browse to and import a content screen file.

4. In the Measured Screen field, browse to and import a laser scan file.
After importing a laser scan file, when performing a system calibration, Mystique Install
calibrates to the laser scan file measurements.

Setting the units of measure
Change the units used for all measurements.

1. In the left pane, click Options.

2. In the System Units list, select the units for all measurements.

Adjusting the System View
The System View is a representation of your configuration that includes the shape of your screen and
the 3D axes of the eye point.

1. Switch to the View tab.

2. In one of the center areas, select System View.

3. Select the options to include in the System View.

• Surface—Show the screen surface.

• Wireframe—Show a wireframe of the screen surface.

• Points—Show the screen surface vertices.

• Origin—Show the X, Y, and Z axes at the location of the origin.

• Eye point—Show the eye point location for the configuration.

• Channels—Show the areas that each projector can reach on the screen with the
configuration.

• Reprojection—Show a heatmap that highlights areas on the projection surface where the
calibration of the configuration can be improved.

• PCD—Show the PCD reference points.

• Cloud—Show the measured point cloud.

4. To rotate the image, click the left mouse button and drag.

5. To change the position of the image, click the right mouse button and drag.

6. To zoom in or out, use the wheel button on your mouse.

Managing the image position and layout
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7. To return to the default axis positions, beside the View list click Reset.

Defining the layout
A channel is a slice of content that is sent to a projector. When defining the layout, the location of
each channel, and where the pixels land within each channel in a configuration are defined.
Values that are entered must match the parameters of the content or image generator. If a
configuration includes projectors that are stacked, channel extent values must be identical for each
projector in the stack.
Define the channel extents for a configuration using one of the following methods:

• Wallpaper (Simple)

• Wallpaper (Advanced)

• Fields of View

• Fields of View (Collimated)

• Projector Centric

Warps are automatically generated so that the projected image matches the layout specified in
Mystique Install.

Defining a single-camera layout
If using a standard projector layout, such as a 2x2 or 2x3 stacked or a simple blended layout, select
Wallpaper (Simple).

Channel layouts are defined by the overlaps between adjacent channels. Once defined, the projected
area of all channels fills the entire screen or playing surface.
For a multi-camera installation, use the Wallpaper (Advanced) layout.

1. In the left pane, click Layout.

2. In the Type list, select Wallpaper (Simple).

3. Select a projector orientation.

4. In the Setup list, select a grid layout.
The options in this menu vary depending on the number of projectors in an installation.

5. In the Content Overlap area, enter the horizontal and vertical blend overlap widths in
percentages or pixels.
If connected to a Pandoras Box Manager, the content overlap values must be entered in
percentages. Verify that the percentage values entered in Christie Mystique Install align with
the channel extent values entered in Pandoras Box.

6. To further inset the projected image, specify the inset percentage values.
A positive inset value creates a black border around the final full image.

7. To make changes to any of the channel extents, click Push Layouts to Wallpaper
Advanced.
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Specifying the properties of a multi-camera layout
If the projector layout is complex, or if content spacing is not uniform across the configuration, select
Wallpaper (Advanced).

The Wallpaper (Advanced) layout is intended for use with multi-camera installations.

1. In the left pane, click Layout.

2. In the Type list, select Wallpaper (Advanced).

3. In the Projector Orientation list, select a projector orientation.

4. Enter the channel extents for each channel in screen-relative percentages.
If connected to a Pandoras Box Manager, the percentage values entered in Christie Mystique
Install must align with the channel extent values entered in Pandoras Box.

To slightly overshoot a screen, set the percentages below 0% or above 100%. This causes the channel
to project past the screen boundary.

Defining the fields of view
When selecting the Fields of View layout, specify the angular extents of each channel by Heading and
by Field of View.

You can also specify a non-zero eye point.

A Eyepoint

B Heading

C Vertical Field of View

D Horizontal Field of View

1. In the left pane, click Layout.

2. In the Type list, select Fields of View.

3. In the Eye Point table, enter the offset from the default center eye point.

• For planar screens, the default eye point is in the middle of the screen.

• For cylindrical or spherical screens, the default eye point is in the center of the curvature.
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• For custom screens, the custom screen definitions determine the x, y, and z offsets.

4. For each channel in the Fields of View Channel Extents table, adjust the yaw, pitch, roll, and
FOV (field of view) settings as required.

• Yaw—The angle of rotation about the Z-axis, describing the left-to-right direction of the
heading of the channel. Forward headings have a yaw of 0, headings to the right are
positive, and headings to the left are negative.

• Pitch—The angle of rotation up towards the Z-axis, describing the up-to-down direction of
the heading of the channel. Horizontal headings have a pitch of 0, headings up towards
the Z-axis are positive, and downward headings are negative.

• Roll—The angle of rotation of the channel about the heading direction (specified by yaw
and pitch). A channel with no rotation about the heading has a roll of 0, channels with
clockwise rotation have positive roll, and channels with counter-clockwise rotations are
negative.

• Left FOV—The angle at the eyepoint from the channel heading to the left edge of the
channel. Angles toward the left are negative.

• Right FOV—The angle at the eyepoint from the channel heading to the right edge of the
channel. Angles toward the right are positive.

• Top FOV—The angle at the eyepoint from the channel heading to the top edge of the
channel. Upward angles are positive.

• Bottom FOV—The angle at the eyepoint from the channel heading to the bottom edge of
the channel. Downward angles are negative.

Changing the values in the Fields of View Channel Extents table
Change the settings for the Fields of View Channel Extents table by copying them to a spreadsheet
application, modifying them, and then pasting them back in to the table.

1. In the Fields of View Channel Extents table, use the cursor keys or drag the mouse to select
several cells.

2. Click the Copy icon.

3. Paste the cells in to a spreadsheet application.

4. Change the values.

5. Copy the cells from the spreadsheet.

6. In Mystique Install, click the upper-left corner of the cell grid to paste into, and then click
Paste.

Defining the collimated fields of view
Specify the parameters for the collimated fields of view projection.

The collimated fields of view projects the field of view data on to a mirror which the viewer can see. In
addition to the settings required for fields of view data, other parameters for collimated projection,
such as the position of the mirror relative to the screen and the radius of the mirror must be specified.

1. In the left pane, click Layout.

2. In the Type list, select Fields of View (Collimated).

3. For each channel in the Fields of View (Collimated) Channel Extents table, adjust the yaw,
pitch, roll, and FOV (field of view) settings as required.
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• Yaw—The angle of rotation about the Z-axis, describing the left-to-right direction of the
heading of the channel. Forward headings have a yaw of 0, headings to the right are
positive, and headings to the left are negative.

• Pitch—The angle of rotation up towards the Z-axis, describing the up-to-down direction of
the heading of the channel. Horizontal headings have a pitch of 0, headings up towards
the Z-axis are positive, and downward headings are negative.

• Roll—The angle of rotation of the channel about the heading direction (specified by yaw
and pitch). A channel with no rotation about the heading has a roll of 0, channels with
clockwise rotation have positive roll, and channels with counter-clockwise rotations are
negative.

• Left FOV—The angle at the eyepoint from the channel heading to the left edge of the
channel. Angles toward the left are negative.

• Right FOV—The angle at the eyepoint from the channel heading to the right edge of the
channel. Angles toward the right are positive.

• Top FOV—The angle at the eyepoint from the channel heading to the top edge of the
channel. Upward angles are positive.

• Bottom FOV—The angle at the eyepoint from the channel heading to the bottom edge of
the channel. Downward angles are negative.

4. In the Eye Point Offset From Mirror Center Point table, specify the X, Y, and Z offset values
from the mirror.

5. Specify the Mirror Location settings, the radius, the yaw, the pitch, and the roll.

6. If necessary, correct any distortion that you see.

Correcting distortion
Use distortion correction to correct small errors in content positioning from the eye-point perspective
and to compensate for the vertical-axis sag that is typical of Mylar mirrors.

Before correcting the distortion, ensure that all other mirror parameters are specified correctly, fine-
tuned, and that a calibration is complete. If distortion correction is used too early, it can result in a
less accurate model of the system in Mystique Install.

1. Switch to the Test Pattern tab.

2. Click Draw.

3. On the projection surface, measure and then record how many degrees the actual vertical
horizon line (bright red dot in the image below) is from the test pattern vertical horizon line
(green line).

4. In the left pane, click Layout.
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5. Click Configure Distortion Correction.

6. In the Pitch table, enter the original value recorded in step 3 and then enter the corrected
value of 0.
There must be a space or a tab between the two values. For example, 0.5 0.

7. Repeat steps 3 to 6 for all vertical corrections.

8. Click OK.
Content from corrected value is mapped to the position of original value.

9. Recalibrate the camera.
a) Switch to the Home tab.

b) In the list next to Run, click Run using analyze results.

10. To correct an error on the horizontal line, repeat steps 1 to 7, but enter the values in the Yaw
table.

Related information

Running a full system calibration (on page 46)

Configuring the Projector Centric layout
Use the Projector Centric layout to display a scene with multiple viewports, and to control the area
covered by each projector.

When the Projector Centric layout is selected, the eye point and angular extents for each channel must
be specified.

1. In the left pane, click Layout.

2. In the Type list, select Projector Centric.

3. In the right pane, for each channel in the Projector Centric Channel Extents table, adjust the X,
Y, Z axes, yaw, pitch, roll, and FOV (field of view) settings as required.

• X, Y, Z—The eyepoint offset of this channel from the default eyepoint. For planar screens,
the default eyepoint is in the middle of the screen. For cylindrical or spherical screens, the
default eyepoint is in the center of the curvature. With custom screens, the custom screen
definitions determine the X, Y, and Z offsets.

• Yaw—The angle of rotation about the Z-axis, describing the left-to-right direction of the
heading of the channel. Forward headings have a yaw of 0, headings to the right are
positive, and headings to the left are negative.

Managing the image position and layout

Christie Mystique Install User Guide 43
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



• Pitch—The angle of rotation up towards the Z-axis, describing the up-to-down direction of
the heading of the channel. Horizontal headings have a pitch of 0, headings up towards
the Z-axis are positive, and downward headings are negative.

• Roll—The angle of rotation of the channel about the heading direction (specified by yaw
and pitch). A channel with no rotation about the heading has a roll of 0, channels with
clockwise rotation have positive roll, and channels with counter-clockwise rotations are
negative.

• Left FOV—The angle at the eyepoint from the channel heading to the left edge of the
channel. Angles toward the left are negative.

• Right FOV—The angle at the eyepoint from the channel heading to the right edge of the
channel. Angles toward the right are positive.

• Top FOV—The angle at the eyepoint from the channel heading to the top edge of the
channel. Upward angles are positive.

• Bottom FOV—The angle at the eyepoint from the channel heading to the bottom edge of
the channel. Downward angles are negative.
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Performing a system
calibration
Before beginning a calibration, verify the following:

• The screen is defined.

• The required cameras are imported, activated, and calibrated (with green calibration
numbers).

• The required projectors are imported and activated.

• Channel extents are defined.

• All points are mapped.

• Camera images are focused.

• Manual exposure and threshold values are correct.

• Images are not over exposed.

Confirming the configuration
After adding and adjusting the corner points, verify that the calibration is set up correctly and that the
screen boundaries and channels are calibrated.

When confirming the layout of your configuration, Mystique Install switches to Camera View. Warping
and blending is turned off, a white test pattern appears on all screens and a red bounding box is
superimposed for each channel in the image. The blue bounding box represents the defined screen.

1. Switch to the Home tab.

2. In the Tools view, click Confirm Layout.

3. Verify that the blue lines trace the outline of the screen, and that the red lines trace where the
channels should be.
If the red bounding box does not appear within the white test pattern, the image is not
displayed in the target position. If the blue outline does not match the layout of the physical
screen, re-calibrate the camera, adjust the horizontal and vertical overlaps, or adjust the
physical or target screen parameters.

Analyzing the configuration
When analyzing the configuration, a mapping between the camera and the projector coordinate
systems is created.

1. Switch to the Home tab.

2. In the Calibration view, click Analyze.
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The display area for the projectors (A), the screen area (B), and the channel areas (C) are
displayed.

Running a full system calibration
Calibrate the cameras in a configuration.

1. To save your current configuration prior to calibrating the cameras, click File > Save.

2. Switch to the Home tab.

3. To begin a full calibration, click Run.

4. To configure automatic camera calibration settings, in the left pane, click Calibration.

Related information

Selecting calibration options (on page 47)

Running a partial system calibration
Learn how to run a partial system calibration.

1. Switch to the Home tab.
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2. In the calibration area, click the list next to Run and select one of the following options:

• Run using analyze results—Use this option if you already confirmed the layout of a
configuration or performed a full calibration, and you want to use the existing mappings
between the camera and projector coordinate systems.
This option should only be used if cameras or projectors have not been moved since the
last analysis.

• Run without automatic camera calibration—Use this option to run a faster system
calibration using the existing camera calibration.

Related information

Confirming the layout of a configuration
Selecting calibration options (on page 47)

Selecting calibration options
Customize the default parameters for calibrations in a configuration.

Christie recommends that you only change these options if you have an advanced understanding of
Mystique Install or if the change is specified by a technical expert.

1. In the left pane, click Options.

2. Expand the Calibration list and modify the settings.

• To tile an image so each projector displays only its portion of a shared input, select Do
Tiling.
This option is not supported on all projectors.

• To save the results of the last successful calibration and use them to speed up future
calibrations, click Save Reference Analysis.
The date and time of last saved analysis is displayed below the button.

• To run a quicker analysis using the last saved calibration, select Fast Analyze.
To select this option, a saved reference analysis must be available.

• To select the order of magnitude that is used to adjust the mathematical model to fit the
collected data, in the Fit Order field, select a value.
Higher values should only be used for more complex situations. Change this option only if
you have an advanced understanding of Mystique Install.

• To select the method used to generate a mathematical model to fit the collected data, in
the Fit Solver list, select an option.

• Projector Centric Planar—This is recommended for use if you are working with
projectors that have standard planar lenses. (Default)

• Least Squares—This is recommended for use only when doing compatibility or A/B
testing.

• RANSAC (Random Sample Consensus)—This is a robust method that can be used in
cases where other methods do not produce expected results.

• Fish Eye—This method provides improved alignment accuracy if you are working with
projectors that have f-theta lenses, or if there is an especially wide field of view.
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• Fish Eye Anamorphic—This method provides improved alignment accuracy if you
are working with projectors that have f-theta and anamorphic lenses, or if there is an
especially wide field of view or aspect ratio.

• PC Planar Anamorphic (Beta)—This method provides improved alignment accuracy
if you are working with projectors that have anamorphic lenses, or if there is an
especially wide aspect ratio.

Masking a projector to a screen
To apply a mask around each channel so that the channel does not project past the edge of a screen,
complete the following steps.

These steps can also be used to manually mask a projector or to correct brightness uniformity.

1. In the left pane, click Options.

2. Expand the Calibration list.

3. To mask a projector to the screen, choose a masking option.

• If no mask is to be applied, select No Masking.
If the Twist file has a previously applied mask, selecting Mask Mappers erases that mask.

• To apply a mask to the shape of the screen geometry, select Mask to Screen.
If the Twist file has a previously applied mask, selecting Mask Mappers erases that mask.

• To retrieve brightness uniformity and masking settings, including Blend Mask, from a Twist
file, select From Twist File.

• To mask out calibration test patterns by the mapper mask layer in the Twist file, select
Mask Mappers.
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Evaluating the content
alignment
Learn how to enable, disable, and switch between warps and blends, and how to apply test patterns to
evaluate the system quality.

Displaying a test pattern
Use test patterns to verify the Mystique Install setup.

1. In the left pane, click Layout.

2. In the Type list, select the layout.

3. Switch to the Test Pattern tab.

4. Configure the test pattern.
The test pattern options change depending on which layout is selected.
Wallpaper test patterns

Option Description

Draw Displays a test pattern on the screen.

Clear Removes a test pattern from the screen.

Grid Density Defines the quantity of the grid lines.

Line Color Defines the color of the grid lines.

Fill Color Applies a fill color to the grid test pattern.

Fields of View test patterns

Option Description

Draw Displays a test pattern on the screen.

Clear Removes a test pattern from the screen.

Grid Color Changes the color of grid points at 1°, 5°, and 90° increments.

Point Size Changes the point size to small, medium, or large.

When 1° grid points are selected, not all grid points are drawn due to a limitation
on the number of grid points that can be displayed.

Fill Color Applies a fill color to the grid test pattern.

Draw Borders Adds borders to the test pattern.

Projector centric test patterns
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Option Description

Draw Displays a test pattern on the screen.

Clear Removes a test pattern from the screen.

Point Size Changes the size of the test pattern markers to small, medium, or large.

Density Defines how the grid markers should be used to draw the test pattern.

Grid Color Changes the color of grid points of the grid axis (Major) and intermediate (Minor)
markers.

Fill Color Applies a fill color to the test pattern.

5. To display a test pattern, click Draw.

Applying warps and blends to a test pattern
To see how the configuration impacts the projector, apply saved warps and blends to a test pattern.

1. Select a projector.

2. Switch to the Projector Control tab and select the warp and blend to display on the selected
projector.

3. Switch to the Test Pattern tab.

4. In the Demo view, select the adjustments to apply to the test pattern.

• Native—Display the projector image without warps or blends.

• Warps & Blends—Display the configured warps and blends.

• Warps Only—Display just the configured warps.

• Blends Only—Display just the configured blends.

Adjusting a warp or blend
Adjust how warps and blends are calculated and saved to a projector.

1. In the left pane, click Options.

2. In the Warping & Blending area, type a name for the definition.

3. In the Mem Location list, select a memory location.

4. To include blend calculations, select Send Blends.
If this checkbox is cleared, blend calculations are not completed and no blending information is
sent to the projectors.

5. To automatically perform brightness uniformity calculations, in the Calculate Brightness
Uniformity list, select one of the following.

• Per Channel—This is the recommended setting. This setting lowers brightness and
contrast values one projector at a time to match other projectors in a configuration.

• Global—This setting takes a full image across all projectors in a configuration adjusting
brightness and contrast values as required.

6. If MotoBlend Blinders are being used, select MotoBlend.

Evaluating the content alignment

Christie Mystique Install User Guide 50
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



If blinders are used, Mystique Install must move the blinders out of the way when performing
a calibration.

Accessing a saved warp
Each projector can store up to 10 custom warp definitions.

1. Switch the Projector Control tab.

2. Select a projector.

3. In the Projector area of the ribbon, select a warp to apply.

Accessing a saved blend
Each projector can store up to five custom blend definitions.

1. Switch the Projector Control tab.

2. Select a projector.

3. In the Projector area of the ribbon, select a blend to apply.

Configuring the options for Twist
To work with a Twist file in Mystique Install, configure the following options.

By default, Mystique Install updates the name of the Twist file to match the name of the Mystique
Install file.

1. In the left pane, click Options.

2. Expand the Twist area.

3. To import to a Twist (.twistx) file, click Browse and navigate to the file.

4. In the Grid Size field, specify the number of grid points that you want the projector to draw
during calibration.
If a grid size greater than nine is specified, the Twist file can only be opened by Twist Pro.

5. To ignore projector undershoot around the border of the screen when performing blend
calculations, select Smart Undershoot Handling.
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Creating a 3D layout
Learn how to use Mystique Install to display content on a 3D object, such as a building.
Before mapping a 3D object, ensure the following:

• All projectors in the 3D layout must support checks and stripes and full pixel blending.

• Each projector in the configuration must be visible by two cameras.

• A laser scan of the object is complete and accurate.

• An object (.obj, .wrl) file and a point cloud data (.pcd) file for the object are complete and
available for upload to Mystique Install.

Guardian and black level blending cannot be used in 3D configurations.

Hardware requirements for 3D configurations
Understand the requirements for creating a 3D configuration.

Only the following cameras can be used with 3D configurations:

• 5.0MP Mono GigE PoE FLIR Blackfly BFLY-PGE-50S5M-C

• 5.0MP Mono GigE PoE FLIR Blackfly BFLY-PGE-50H5M-C

3D configurations are supported on the following projectors:

• Crimson HD25

• Crimson WU25

• Boxer 4K20

• Boxer 4K30

Stacked projectors are not supported.

Workflows
Understand the different ways of creating and calibrating a 3D configuration.

• Manual calibration (on page 18)—Requires an operator to manually identify correspondences
between model features in the CAD model and the same features as seen through each
camera.

• ACT calibration (on page 17)—Performs a 3D calibration using an ACT device.

• Structured light calibration (on page 16)—Requires minimal manipulation of known
calibration data to align the model and camera.
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Structured light calibration workflow for 3D layouts
Create a 3D layout by aligning the point cloud provided with the 3D model and the point cloud
generated by Mystique Install.

1. Add the projectors throwing light onto the surface (on page 23).

2. Switch to the Projector Control tab.

3. To enhance the contrast on the projection surface, making the edges and features more visible
to the cameras, select a projector and set it to use a combination of black and gray test
patterns.

4. Switch to the Install tab.

5. Add the cameras that can view the projection surface (on page 27).

6. (Optional) Manually set the exposure for the cameras (on page 55).

7. Select the 3D model (on page 56).

8. Expand the Calibration pane, and select Structured Light.

9. Configure the Structured Light settings (on page 57).

10. Gather the information about the scene through test patterns and projector associations (on
page 57).

11. Click Baseline Camera Calibration.

12. Generate a point cloud of the scene from the projector and camera associations and the
calibrations (on page 58).

13. If the point cloud has data that is not relevant to the model, remove all unnecessary points (on
page 58).

14. Align the point cloud with the model.
a) To change the angle of the viewport contents, right-click and adjust the orientation of the

point cloud.

b) Click Reorient Point Cloud.

c) Click and drag three points of the camera point cloud onto the corresponding locations on
the model.

15. Align the generated point cloud with the model point cloud data. (on page 59)

16. Evaluate how closely the scene point cloud matches the model point cloud.
The two point clouds must overlap exactly. If the matching does not appear to be exact, repeat
steps 13 to 16.

17. Determine the position of the projectors (on page 59).

18. To verify the layout is correct, draw a test pattern on the model (on page 60).
If the layout must be corrected, repeat steps 13 to 18.

19. Blend the content areas for all projectors in the configuration (on page 60).

20. To transfer the projector and camera location information to the content system, export the
calibration file.

ACT calibration workflow for 3D layouts
Perform a 3D calibration using an ACT device.

1. Add the projectors throwing light onto the surface (on page 23).
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2. Switch to the Projector Control tab.

3. To enhance the contrast on the projection surface, making the edges and features more visible
to the cameras, set the projectors to use a combination of black and grey test patterns.

4. Add the cameras that can view the projection surface (on page 27).

5. (Optional) Manually set the exposure for the cameras (on page 55).

6. Select the 3D model (on page 56).

7. Calibrate the cameras using an ACT device (on page 31).

8. Gather the information about the scene through test patterns and projector associations (on
page 57).

9. Create a point cloud of the scene from the projector and camera associations and the
calibrations (on page 58).

10. If the point cloud has data that is not relevant to the model, remove all unnecessary points (on
page 58).

11. Align the generated point cloud with the model point cloud data. (on page 59)

12. Evaluate how closely the scene point cloud matches the model point cloud.
The two point clouds must overlap exactly. If the matching does not appear to be exact, repeat
steps 11 to 13.

13. Determine the position of the projectors (on page 59).

14. To verify the layout is correct, draw a test pattern on the model (on page 60).
If the layout must be corrected, repeat steps 11 to 15.

15. Blend the content areas for all projectors in the configuration (on page 60).

16. To transfer the projector and camera location information to the content system, export the
calibration file.

Related information

Automatically calibrating the camera using a Christie ACT device (on page 31)

Manual calibration workflow for 3D layouts
Manual Calibration relies on an operator finding correspondences between model features in the CAD
model and the features seen through the cameras. For each correspondence, the feature must be
visible by a minimum of two cameras. Six correspondences are required per camera.

Prior to each subsequent alignment, ensure that the correspondences align with the marked features.

1. Add the projectors throwing light onto the surface (on page 23).

2. Switch to the Projector Control tab.

3. To enhance the contrast on the projection surface, making the edges and features more visible
to the cameras, set the projectors to use a combination of black and grey test patterns.

4. Add the cameras that can view the projection surface (on page 27).

5. (Optional) Manually set the exposure for the cameras (on page 55).

6. Select the 3D model (on page 56).

7. Manually calibrate the cameras (on page 56).

8. Gather the information about the scene through test patterns and projector associations (on
page 57).
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9. Create a point cloud of the scene from the projector and camera associations and the
calibrations (on page 58).

10. If the point cloud has data that is not relevant to the model, remove all unnecessary points (on
page 58).

11. Align the generated point cloud with the model point cloud data. (on page 59)

12. Evaluate how closely the scene point cloud matches the model point cloud.
The two point clouds must overlap exactly. If the matching does not appear to be exact, repeat
steps 11 to 13.

13. Determine the position of the projectors (on page 59).

14. To verify the layout is correct, draw a test pattern on the model (on page 60).
If the layout must be corrected, repeat steps 11 to 15.

15. Blend the content areas for all projectors in the configuration (on page 60).

16. To transfer the projector and camera location information to the content system, export the
calibration file.

Manually adjusting camera gain and exposure
By default, camera gain and exposure are automatically adjusted by Mystique Install.

Adjust the gain and exposure settings until a high contrast in projected light is observed in the camera
view. Before completing this task, Christie recommends setting the projector to display a high contrast
test pattern, such as a grid test pattern.

1. In the left pane, click Camera.

2. Select a camera.

3. Expand the Camera Exposure area.

4. In the list, select Manual.

5. Do one of the following.

• To adjust the brightness of the camera image, drag the Gain slider back and forth or click
the - and + buttons.

• To adjust the amount of time the camera shutter stays open when capturing images, drag
the Exposure slider back and forth or click the - and + buttons.

• To adjust the camera exposure to display the maximum contrast between projected white
light and black, click Show High Contrast Pattern.

6. Repeat steps 2-5 for all cameras.

Related information

Displaying a test pattern (on page 49)
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Specifying a model
Specify an object model by uploading a supported object (.obj or .wrl) file and a point cloud data
(.pcd) file to Mystique Install.

Before completing this task, verify that the PCD view is enabled on the View tab at the top of the
screen.

1. In the left pane, click Model.

2. To set the unit of measure, in the Scene Units list, select an option.

3. Under Content Model, upload the following files.

• Mesh—Upload an .obj or .wrl file.
The object model appears in the System View.

• PCD—Upload, a .pcd file.
The point cloud appears over the object model in the System View.

4. Select the measurement units used in the content model.

5. Set the orientation so the model is facing the same direction as it appears in the content
system.
If one axis is selected as Forward, the same axis (+ or -) cannot be selected as Up. The default
settings are Y Forward and Z Up.
The orientation is applied to the loaded model, including both the point cloud (PCD) and Mesh
(OBJ/WRL) files.

Manually calibrating cameras
Every camera in a 3D layout must be calibrated.

1. In the left pane, click Calibration.

2. Select Manual Markers.

3. Switch the view to a two-pane view, with one pane displaying the System view and the other
displaying a camera view.

4. Select a camera.

5. Place markers in the System View pane.
a) In System View, zoom in on the model.

b) To add a marker point, hover the mouse pointer over an identifiable feature, press Alt and
left-click on the feature.

c)

d) To adjust the placement of a marker point, in the Screen Markers table, increase or
decrease the X, Y, or Z values for the marker point.

A minimum of six markers must be placed, and two of the six points should be shared by each
camera in a camera pair.
When adding marker points, Christie recommends adding points to identifiable features that
appear on both the model in System View, and are visible to the camera in Camera View.
Avoid adding markers to void spaces of the model, such as windows on a building, as these
may not be clearly visible to the camera.
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In some cases, angling the view upwards can help to ensure that a marker point is added to
the intended feature. Christie recommends avoiding coplanar points. When calibrating a 3D
layout, it is beneficial for marker points to have depth.

6. Drag a marker point from System View to the corresponding feature in Camera View. Repeat
this step for all markers in the Camera View.
Selected markers turn yellow.
To zoom in on the model and place markers in specific locations, press CTRL and scroll in with
the mouse.
After at least six points have been identified on the camera view, the distance between two
points on the system view is compared to the distance between the same two points on the
camera view, and the accuracy of the points is analyzed.

7. To view the accuracy of the points, change to a four-pane view.
The results are displayed in the <Camera name> Calibration pane, and the accuracy is color-
coded.

• Green—Good match

• Yellow—OK match

• Red—Poor match

A camera is correctly calibrated when the dX and dY values in the Camera Calibration table are
green for all marker points.

8. For any markers that have red values, verify that the camera view marker is as close as
possible to the location of the system view marker.
To adjust the placement of a marker point in system view, press and hold Ctrl and move the
marker point until the dX and dY values for the marker point turn green.
In rare cases, a marker point may appear to be on a feature, but the dX and dY values are not
green. Or, the dX and dY values turn green when a marker point is not on a feature. If this
occurs, adjust the marker point until it appears correctly on the feature in the System View.
If the marker calibration cannot be improved, the model file or laser scan may be inaccurate.

9. Repeat steps 4 to 8 for each camera in the 3D layout.

Configuring and gathering structured light
To map projector pixels to camera pixels, perform the Gather operation.

Camera images are gathered for each stereo pair.

1. In the left pane, select Options > Locate and modify the settings as needed.

• Collect Inverses—If elements in the configuration move while light is being gathered,
increase the bit plane collection.

• Structured Light Patterns to Skip—Select the number of bit planes the cameras should
skip when gathering structured light.

• Collect using Camera pairs—Data is collected from one projector and two cameras
independently from other camera pairs. Select this option when you don't want one pair of
cameras contributing data to the point cloud data gathered by a different pair of cameras.
This must not be selected when using Structured Light calibration, which requires three or
more cameras.

• Camera Collection Threshold—The percentage of pixels the camera must use to identify
the output of a projector. If the camera is using fewer pixels, the data from the camera is
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excluded from the calculation. This is only available when Collect using Camera pairs is
disabled.

2. Switch to the Install tab.

3. Click Gather.
When the Gather operation is complete, a verification test pattern is displayed by all projectors
in the layout.

4. After performing a Gather operation, assess the results.

Test Pattern Description

Solid green Both cameras in a stereo pair are in agreement and can see the pixels
coming from a projector.

Yellow point A pixel was visible by only one camera in a stereo pair.

Magenta A pixel was not seen at all by the cameras in a stereo pair.

Green and magenta
checkerboard

The camera to projector pixel mapping does not line up and the Gather
operation was unsuccessful.

Generating the point cloud
Generate a point cloud of 3D points on the projection surface using the camera-projector
correspondences collected in the Gather operation and the camera calibration values.

1. After successfully executing the Gather operation, select Options > Generate Point Cloud
and modify the settings as necessary.

2. To remove projector dots that are sensed outside of the intended area during the decode
process, select Enable Automatic Noise Filtering.

3. Switch to the Install tab.

4. Click Generate Point Cloud.
The point cloud appears in multiple colors. All points of a single color are facing the same
direction.

5. If the point cloud is difficult to see, adjust the size of the points in the cloud.

• To make the points larger, press ALT+SHIFT and scroll up with the mouse wheel.

• To make the points smaller, press ALT+SHIFT and scroll down with the mouse wheel.

Cropping points from the point cloud
After generating the point cloud, if the cloud does not match the .pcd file, crop unnecessary points
from around the object, increasing the success of automatic alignment.

If the Generate Point Cloud operation resulted in the point cloud not appearing on the model, perform
the Locate operation before cropping the point cloud.

1. Switch to the View tab.

2. To view the .pcd file in System View, click PCD.

3. In the left pane, select Options > Locate.

4. In the Cropping Distance field, enter the radius in meters around the object.
Any points outside of this distance will be removed.
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5. Switch to the Install tab.

6. Click Crop Point Cloud.

7. Repeat steps 1-6 until the point cloud matches the .pcd file.
If the point cloud is cropped too much, to recover the original point cloud click Generate
Point Cloud.

Related information

Locating the model (on page 59)

Locating the model
Automatically move the generated point cloud on to the model, and align it with the .pcd.

Each time this operation is executed, the point cloud is moved. This operation may be executed
repeatedly until the results appear as expected.

1. In the left pane, select Options > Locate and modify the settings as needed.

• Cropping Distance—Points that are beyond the distance entered in this field are
discarded.

• Point Fit Distance—Points that fall within the distance entered in this field are fitted to
the model. The calculation is approximately sqrt(model size in meters)/100. For
example, for an 80 meter building, the calculation would be sqrt(80)/100 = 0.089m
(~9cm). The default distance is 5cm.

• Number Of Points To Fit—The number of points that are used to establish a point cloud
fit to the model. The calculation is approximately 10,000*(number of projectors). The
default value is 10,000.

• Adjust Scale—Helps to determine the scale factor of the model.

2. Switch to the Install tab.

3. Click Locate Model.

4. Repeat step 3 as necessary.

Related information

Cropping points from the point cloud (on page 58)

Solving the layout
Determine the positions of the projectors in a 3D layout.

1. Select Options > Solve.

2. In the MPCDI field, select a file.

3. Switch to the Install tab.

4. To export the file to a media server, click Solve.
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Exporting a 3D layout
If the content system does not receive the configuration details after Solve, manually enter the
parameters of the configuration.

1. Switch to the Install tab.

2. Click Export Dialog.

3. In the Solved Projector Positions dialog, in the Format list, select a content system.

4. Copy the values from the dialog, and paste them into the content system.

Drawing a 3D test pattern
To verify the accuracy of the layout after running Solve, draw a 3D test pattern on the object.

1. Switch to the Install tab.

2. Select Draw 3D Test Pattern.

3. Assess the results on the object.
If the alignment results are not as expected, try any of the following.

• Review the orientation and fit of the point cloud, and run the camera calibration again.
If alignment results are still not as expected, it is possible the model used is not an
accurate representation of the object.

• Separate the model in to sections and align each section individually.

4. To remove the test pattern, click Clear Test Pattern.

Applying blends to a 3D layout
Blends apply a mask that can hide minor misalignments in a layout.

Black level blending cannot be used in 3D configurations.

1. Select Options > Blend and modify the settings as needed.

• Mask Width—The width of the edge mask.

• Blend Name—The name of a blend.

• Blend Location—The memory location of the blend on a projector.

2. Switch to the Install tab.

3. Click Apply Blends.
Blend data, such as which area of light is owned by one projector or shared by more than one
projector, can be obtained in the blend.bmp file that is a part of the log files for the layout.

4. To clear blends from the layout, select Clear Blends.
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Recalibrating a 3D layout
After a full calibration has been completed, if a hardware component moves, a recalibration will be
required.

The method for recalibrating a configuration depends on the original method of calibration.
For ACT calibrations, if the ACT markers are still in place on the 3D object, perform the calibration
with the ACT device again.
For Manual calibrations and Structured Light calibrations, the configuration files save the
reference positions for all cameras. If the cameras have been moved too far from the saved position, a
recalibration is required. To recalibrate the configuration, perform the steps below.

1. Load the calibration file.

2. (Optional) On the Home tab, click Run Options and select the functions of the calibration to
run during the recalibration, and set any options associated with those functions.
To clear the test patterns and allow the media server content to play through the projectors,
click Show Content.

3. Click Run.

Related information

Generating the point cloud (on page 58)
Cropping points from the point cloud (on page 58)
Drawing a 3D test pattern (on page 60)
Applying blends to a 3D layout (on page 60)

Creating a 3D layout

Christie Mystique Install User Guide 61
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



Configuring black level
blending
To reduce the visibility of projector overlaps when displaying extremely dark content, blend the black
level light of multiple projectors.
Black level blending is not available with the Essentials edition of Mystique Install.
Before trying a black level blend, ensure that the following settings and options are in place:

• The projectors needing black level blending are the same model of projector.

• In the left pane, under Options, select Options > Fit Solver > Projector Centric Planar.

• Ensure that the alignment quality of the warps in the configuration are excellent. If warps are
not perfect or nearly perfect, black level calculations are not successful.

• Ensure that the projectors in the configuration are both power and color balanced.

• If one or more projectors in a configuration uses a fish eye lens, verify that all pixels the DMD
are covered by the lens. If any are not covered, replace the fish eye lens with a planar lens.

Loading a previously saved black level blend
Learn how to view a saved black level blend.

When saving a black level blend, Mystique Install stores the blend as a black level profile. A black level
profile applies to all projectors in a configuration. Up to four black level profiles can be stored in
Mystique Install.

1. Switch to the Black Level Blending tab.

2. Expand the Black Level Profile list and select a profile.

3. Click Render Black Level.

Estimating projector black levels
To estimate the black level value of a projector, use the black level projector preview.

Each projector in a configuration has a different black level light value, relative to the white value of
the projector. To create a black level blend, estimate the black level for each individual projector in the
configuration.
In some cases, when previewing black level values artifacts appear on the projection surface. These
artifacts do not appear when final black level blends are applied.

1. In the left pane, click Black Level Blending.

2. Select Enable Black Level.

3. Under Black Levels, select a projector and click Preview.

4. On the projection surface, examine the exterior edges of the overlaps for the projector.
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5. Complete the following.

• If the adjacent projectors are brighter than the edges of the projector you are previewing,
under Black Level (%), decrease the black level contribution value for the projector.

• If the adjacent projectors are darker than the edges of the projector you are previewing,
under Black Level (%), increase the black level contribution value for the current
projector.

6. Repeat steps 2-5 until the edges of the projector overlaps disappear.
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7. Repeat this process for all projectors in the configuration.

Evaluating overall uniformity
The black levels for each projector in a configuration must be estimated before evaluating the overall
uniformity of a black level blend.

1. Switch to the Black Level Blending tab and select Enable Black Level.

2. In the Black Level Method list, select Uniform Blend.

3. Click Render Black Level.

4. To fine-tune the adjustments, try any of the following.

• In the Black Levels view, under Black Level (%), adjust the contribution value for the
projectors.
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• If there is a gap or an overlap on an edge, in the Black Levels view, adjust the Pond of
Mirrors value for the edge.
 

 

• If a specific projector appears too bright, in the Black Levels view, lower the boost factor
value.
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• If a specific projector appears too dark, in the Black Levels view, increase the boost factor
value.

5. Click Render Black Level.

Adjusting the quality of a black level blend
After adjusting the correctness of the blend using the black level, pond of mirrors, and boost factor
values, finalize the blend by modifying its appearance.

The perception of blend quality can change based on the viewing angle and distance from the
projection surface. Christie recommends evaluating the quality of the blend from a perspective that is
as close to the viewpoint of the audience as possible.
To achieve a final blend result, and to preserve contrast without highlighting the areas of change,
complete the following steps.

1. Click Black Level Blending.

2. Select the Black Level Method.

• Uniform Blend—Attempts to completely mask black levels across the projection surface.

• Influential Blend—Applies a blend based on the largest nearby intensity change for an
overlap region.

• Cumulative Blend—Applies a blend based on the combined influence of all nearby
overlap regions.

Influential and Cumulative blends require a Black Level Drop Off value.

3. To add additional light to overlap regions between projectors in a configuration, adjust the
Added Black Light value.
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Adding black light can help to disguise intensity or color transition and balances the black level
blends.

4. To match intensity levels between projectors in a configuration and blur overlap zones into the
non-overlap zones, increase the amount of light used across a black level blend by adjusting
the Black Level Drop Off value.
This value is measured in the unit of distance of the projection surface. Increasing this value
can help in situations where projectors are difficult to balance, are improperly color matched,
or where there are warp inaccuracies.

5. Click Render Black Level.
If you switch between black level methods, it might be necessary to adjust the black level and
boost values. A set of values that appears well balanced in one method might require
adjustments to appear well balanced in another method.

Related information

Adjusting the quality of a black level blend

Saving a black level blend
Save up to four black level blends for later reference.

When saving a black level blend, a black level profile is saved in the projector memory. A black level
profile applies to all projectors in a configuration.

1. In the left pane, click Options.

2. In the Warping & Blending area, in the Name field, enter a name.

3. In the Mem Location list, select a memory location.

4. To include blend calculations, select Enable Blending.

5. To save a black level blend, select Home > Run.
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Maintaining the
alignment of a projected
image with Guardian
Configure Guardian to perform analysis and calibration of live content, and monitor projector
positioning to ensure the content is always aligned.
Guardian functionality is only available with the Guardian add-on to the Essentials and Pro-Venue
editions of Mystique Install. To purchase the Guardian add-on, contact your Christie sales
representative.
Guardian supports both flat and curved screens. Only single-camera configurations are supported, and
the camera must be able to see the entire screen.

Guardian does not work for 3D configurations, or image-based alignment. Guardian is only supported on
Windows 10 operating systems.

If the camera drifts off its alignment, projector content will also drift. Alignment between projectors is
maintained, but alignment to the screen itself will drift. To avoid vibration or drift, mount the cameras.
Guardian is only supported on Windows 10.

Guardian requirements and limitations
Understand the requirements and limitations for systems to run Guardian.

Hardware requirements
Only the following cameras can be used with Guardian:

• 5.0MP Mono GigE PoE FLIR Blackfly BFLY-PGE-50S5M-C

Guardian is supported on the following projectors:

• Crimson HD25, firmware version 1.1 or later

• Crimson WU25, firmware version 1.1 or later

• Boxer 4K20, firmware version 1.6 or later

• Boxer 4K30, firmware version 1.6 or later

• D4K40-RGB, firmware version 1.0.0 or later

Ensure the projectors are running the latest firmware.

Additional requirements:

• All projectors in system must be the same model.
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• All projectors in system must have the same model and revision of input card, and the cards
must be installed in the same slot.

• The GPIO camera trigger cable (P/N: 156-133108-XX) must be connected between one of the
projectors in system and the camera.

System requirements
• The network must be only used for Mystique, including only the camera, projectors, and

Mystique Install computer. Do not include Pandoras Box servers or other network devices on
the Mystique network.

• The camera requires a Power over Ethernet (PoE) switch or injector.

• Do not use more than a single switch between devices.

• Christie recommends a minimum screen brightness of 2 ft-L for best results.

• Before running a Guardian calibration for the first time, the camera lens' manual aperture
should be set wide open (or to the lowest f-stop).

• Guardian is only supported on Windows 10

Content recommendations
• Content must be frame-locked on all outputs, run between 50Hz and 60Hz, or run at 120Hz.

• Guardian can only monitor and correct alignment during periods of bright content. Correcting
alignment requires an approximate brightness greater than ~30% in at least one of three color
channels (specifically greater than 72 out of 255) for a period of at least 30 seconds per
projector.

• Guardian can only calibrate when there is a signal to the projector. If no signal is present,
visible structured light patterns have to be used.

Configuring and starting a Guardian calibration
Configure Guardian so if it is determined that the position of a projector has moved, the content is
automatically adjusted and realigned. This process is invisible to anyone viewing the content.

1. Set up the configuration, including the screen and all projectors and cameras, and perform a
smooth screen calibration.
This ensures the configuration is correct, and saves a reference analysis which can be used
with the Fast Analyze feature. It is expected that good warps and blends have been uploaded
to all projectors before beginning the Guardian calibration steps.

2. Connect the Guardian GPIO cable between the projector and camera.

3. On the Home tab, click Guardian Health.

Running Guardian Health will interrupt the content and display light on the screen.

All the components of the configuration are checked to ensure they meet the criteria for
Guardian calibration. Any issues that must be resolved are listed in the Status Viewer.
A successful Guardian configuration displays the message "System is ready for Guardian" in
the Status Viewer.

4. Expand the Options area.
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5. To ensure the generated warps contain similar geometric properties to the previously uploaded
warps, in the Warping and Blending area select Warp Validation.
If a difference is found, the new warps are not uploaded to the projectors

6. To retry the analysis on a projector if the gathered data does not cover the channel, select
Validate Analysis.

7. To speed up the gathering of data from the scene, save a Reference Analysis and enable Fast
Analyze.
Christie recommends saving a reference analysis from a visible light calibration.

8. In the Calibration area, select the type of Mapper Encoding.

• Default—Recommended encoding for most configurations.

• Extended—Provides redundancy during calibration for unexpected objects moving
through the camera view, such as a Zamboni or an insect. Extended encoding takes a
longer to complete.

9. To ignore calibration data gathered from black areas of the content, which can produce
misinterpreted calibration results, select Content Masking.
Ignoring the data collected from black areas of content allows the calibration to be based on
the areas of the content it can analyze, eliminating alignment and calibration issues caused by
the misinterpreted results. When enabled, if Guardian is presented with an all black frame any
calibration data gathered to that point is removed and the calibration fails.
Do not use content masking if the content has frames that are completely black.
If the Content Masking checkbox is not selected, data is gathered from all areas of the content.

Christie strongly recommends against using Extended encoding and Content Masking at the
same time. The combination of these settings creates a longer Gather period, providing more
opportunity for black content to appear during the calibration, and a higher risk of the
calibration failing.

10. Before running a Guardian calibration for the first time, the camera lens' manual aperture
should be set wide open (or to the lowest f-stop).

11. To start Guardian, click Guardian Calibration.
When the projector enters Guardian mode, there may be small flicker in the projected content.

Monitoring a Guardian calibration
Remotely monitor and calibrate a Guardian configuration with Mystique Operate Lite.

For additional information on Mystique Operate Lite, refer to Mystique Operate Lite Instruction Sheet
(P/N: 020-102382-XX) and Mystique Operate Lite API Commands Guide (P/N: 020-102628-XX).

Adding scenes in Mystique Operate Lite
Learn how to add a scene or a list of scenes to Mystique Operate Lite.

A scene is a single screen or surface consisting of projectors and cameras. To control alignment, each
scene requires a unique Mystique Install .cal file.
Applications that use 3D Stereoscopic projection with independent projector channels for each eye
require two .cal files—one for each eye.

1. On the Settings page, click Add.

2. To change the name of a scene, click the scene name.
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3. In the file path field, type the full path to the .cal file.
The .cal file must be located on the computer running Mystique Operate Lite.

4. If required, do any of the following.

• To reorder a scene in a list of scenes, drag and drop a scene to another place in the list.

• To delete a scene, drag a scene to the Trash icon and drop it.

5. To save your settings, click Save Changes.
If there is an error with a scene, a message appears at the top of the screen.

6. To open the Home page, at the top of the screen click Home.

Controlling Guardian from Mystique Operate Lite
To perform tasks on a Guardian scene such as starting or stopping Guardian, or running a calibration,
navigate to the Home page.

1. Open Mystique Operate Lite.

2. In the Scene list, select a Guardian scene.

3. To turn the continuous Guardian monitoring on and off, click Guardian Protection.

4. To run an invisible, one-time heal with Guardian calibration, click Heal Now.

5. To perform additional diagnostics, click >> and do any of the following.

Performing any of these operations will interrupt the content and display light on the screen.

• To run a calibration, click Run Calibration.

• To display a test pattern, click Test Pattern.

• To remove a test pattern and display the content from the input signal, click Clear.

6. To cancel an operation, click Cancel.

7. To view the status of the Guardian operation, including any failed runs or errors, review the
information below the Heal Now button.

If there is a part of the content that has enough light to perform a successful Guardian calibration, use
the Operate REST API to synchronize the Heal command to run at the correct time.

Maintaining the alignment of a projected image with Guardian

Christie Mystique Install User Guide 71
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



Mapping a playing
surface
When using the Pro Venue, Premium, or Large Scale Experience edition of Mystique Install, images
can be projected on a playing surface, such as a basketball court or a hockey rink.

Requirements for mapping a playing surface
Before you begin an installation, ensure the following is complete.

• Camera position—Identify where the camera will be mounted in the facility. The camera must
be in a position where it can see the entire playing surface. Christie recommends placing the
camera as high as possible, for example by the broadcast booth, for the widest field of view in
the camera image.
Typically, one camera is required for mapping a playing surface.

• Projectors and projector layout—Confirm the number of projectors required for the
installation, and identify where and how they will be mounted above the playing surface.

• Reference image—Christie recommends using an image of the arena surface to align the
projectors. The image that is used must match the aspect ratio of the playing surface. Any
markings on the surface, such as face-off circles or goal lines, should be accurately positioned
in the image. This image must be in .png format.

• Media server channel information—To complete the configuration in Mystique Install, you
must know how the content will be sliced and sent to each projector. You must also know the
projector layout and determine whether blend sizes are calculated in pixels or as a percentage.
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To arrange a site survey, contact Christie technical support.

Adding devices to a configuration
Learn how to add a camera and projectors when mapping a playing surface.

Searching for a projector
Search by port number when adding a projector to the configuration.

The projector must be on the same subnet as the computer when searching by port number.

1. In the left pane, click Projector.

2. Click Add.

3. Click Search.

4. Select a projector.

5. Click OK.

Manually adding a projector to a configuration
If a projector is not automatically detected, or if it is not on the same subnet as other projectors in a
configuration, you can manually add the projector to the configuration by entering the projector IP
address and port number.

To manually add a projector to a configuration, you must know the IP address and port number of the
projector. To find the IP address of a projector, refer to the projector documentation.

1. In the left pane, click Projector.

2. Click Add.

3. On the Manual tab, type the IP Address and Port number of a projector.

4. Click Search.

5. Select the projector.

6. Click OK.

Connecting a Pandoras Box Manager as a projector
Learn how to add a Pandoras Box Manager as a projector in Mystique Install.

When connecting to a Pandoras Box Manager, each output in a Pandoras Box project appears as a
projector in Mystique Install. While Mystique Install can connect to one Pandoras Box Manager at a
time, multiple Pandoras Box Clients can be connected to a single Manager.
Mystique Install, the Pandoras Box Manager, and all Pandoras Box Clients must be configured for, and
run on, the same network.
If the configuration uses 4K projectors, to have the entire display as a single camera and a single
output in the Pandoras Box Manager change the graphics card settings on the computer to Mosaic or
Surround mode. Then, in Mystique Install, connect to the Pandoras Box Manager.
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For a blend for Pandoras Box to appear as expected, Christie recommends using projectors that can
support a gamma curve of 2.2, such as Christie 3-chip DLP projectors. Otherwise, blend quality can
vary.

1. In Pandoras Box Manager, verify that the project file containing the content is open.

2. In Mystique Install, in the left pane, click Projector.

3. Click Add.

4. Do one of the following.

• If the Pandoras Box Manager is installed on the computer used to run Mystique Install,
from the Search Results list, select PB Devices.

• If the Pandoras Box Manager is installed on another computer, or PB Devices does not
appear in the Search Results list, switch to the Manual tab. Type the IP address of the
Pandoras Box Manager, and click Search or Clear & Search.

5. Click OK.

Once you connect to a Pandoras Box Manager, canvases for warping, blending, and test patterns are
created in the Pandoras Box project. Establishing a consistent communication stream might take
longer than expected.
When Mystique Install is run, warps and blends are added to the output and activated in Pandoras Box
Manager.
Some projector controls, such as power and shutter controls, are unavailable when connected to a
Pandoras Box Manager.

Adding a camera to a playing surface configuration
To add a camera to a configuration, complete the following steps.

1. Open or create a configuration file.

2. In the left pane, click Camera.

3. Click Add.

4. Select the camera.

5. To see a recently connected camera, click Refresh.

6. Click OK.
When a camera is added, a preview of the camera image appears in the Camera View.
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Defining the playing surface layout
A channel is a slice of content that is sent to a projector. When defining the layout, the location of
each channel, and where the pixels land within each channel in a configuration are defined.
Values that are entered must match the parameters of the content or image generator. If a
configuration includes projectors that are stacked, channel extent values must be identical for each
projector in the stack.
Define the channel extents for a configuration using one of the following methods:

• Wallpaper (Simple)

• Wallpaper (Advanced)

Warps are automatically generated so that the projected image matches the layout specified in
Mystique Install.

Defining a single-camera layout
If using a standard projector layout, such as a 2x2 or 2x3 stacked or a simple blended layout, select
Wallpaper (Simple).

Channel layouts are defined by the overlaps between adjacent channels. Once defined, the projected
area of all channels fills the entire screen or playing surface.
For a multi-camera installation, use the Wallpaper (Advanced) layout.

1. In the left pane, click Layout.

2. In the Type list, select Wallpaper (Simple).

3. Select a projector orientation.

4. In the Setup list, select a grid layout.
The options in this menu vary depending on the number of projectors in an installation.

5. In the Content Overlap area, enter the horizontal and vertical blend overlap widths in
percentages or pixels.

Mapping a playing surface

Christie Mystique Install User Guide 75
020-001134-05 Rev. 1 (01-2019)
Copyright © 2019 Christie Digital Systems USA, Inc. All rights reserved.



If connected to a Pandoras Box Manager, the content overlap values must be entered in
percentages. Verify that the percentage values entered in Christie Mystique Install align with
the channel extent values entered in Pandoras Box.

6. To further inset the projected image, specify the inset percentage values.
A positive inset value creates a black border around the final full image.

7. To make changes to any of the channel extents, click Push Layouts to Wallpaper
Advanced.

Specifying the properties of a multi-camera layout
If the projector layout is complex, or if content spacing is not uniform across the configuration, select
Wallpaper (Advanced).

The Wallpaper (Advanced) layout is intended for use with multi-camera installations.

1. In the left pane, click Layout.

2. In the Type list, select Wallpaper (Advanced).

3. In the Projector Orientation list, select a projector orientation.

4. Enter the channel extents for each channel in screen-relative percentages.
If connected to a Pandoras Box Manager, the percentage values entered in Christie Mystique
Install must align with the channel extent values entered in Pandoras Box.

To slightly overshoot a screen, set the percentages below 0% or above 100%. This causes the channel
to project past the screen boundary.

Mapping the marker points on a playing surface
Before calibrating a configuration of a playing surface, identify the features on the playing surface you
want to calibrate to.

When using a reference image to align the projectors, the reference image must match the aspect
ratio of the playing surface. Any markings on the surface, such as face-off circles or goal lines, should
be accurately positioned in the image. This image must be in the format of a .png file.

1. In the left pane, click Screen.

2. In the Shape list, select Flat.

3. In the Determine Size list, select From Image.

4. In the Marked Surface Image field, browse to the reference image.
The reference image appears in the Marked Surface Image view, with marker points appearing
at the corners of the image.

5. In the Marked Surface Image view, move the marker points to four features of the playing
surface visible to the camera that you want to calibrate to. For example, if mapping a hockey
rink, you can move the marker points to the face-off circles.
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Calibrating the camera
When mapping a playing surface, match the marker points on the reference image to the
corresponding points on the physical playing surface in Camera View.
There are two camera calibration methods that can be used.

• Manual calibration—When using this method, calibration data is saved as part of your .cal
file, however, the calibrated camera image is not saved. If the camera is unintentionally moved
out of position, the camera must be recalibrated manually using the original reference image.

• Image-based calibration—After calibrating the camera, using the calibrated camera image,
take a new reference image. When using this method, if the camera is unintentionally moved
out of position, it can automatically be recalibrated to align with this new reference image.

Calibrating a playing surface configuration manually
After mapping the marker points of a playing surface in the Marked Surface Image View, match the
marker points what the camera sees in Camera View.

1. In the left pane, click Calibration.
The Camera View appears with a transparent overlay of the mapped reference image.

2. In the Camera View, zoom out until the marker points are visible.

3. Adjust the marker points so that the transparent overlay of the reference image matches the
camera image of the playing surface.
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4. To increase or decrease the opacity of the transparent overlay, move the Opacity slider to the
right or to the left.

5. To make fine adjustments to the corner points, press and hold the CTRL key, and move the
calibration points as required.
The dX and dY values turn green when the corner points are correctly calibrated.

6. Perform a manual calibration.
a) Switch to the Home tab.

b) Click Run.

The calibration data is saved as part of your .cal file, however the camera image is not saved.

Performing an image-based calibration on a playing surface
An image-basaed calibration may be performed if the screen size is determined using an image.

Christie recommends only performing image-based calibrations in settings where lighting conditions
are consistent. If lighting conditions change between calibrations, manual camera calibration might be
required.
After calibrating the camera, take a new reference image so that if the camera is unintentionally
moved out of position, it can automatically be recalibrated to align with the new reference image.

1. Open or create a configuration file.

2. In the left pane, click Calibration.

3. In the Camera View, zoom out until the marker points are visible.

4. Adjust the marker points so that the transparent overlay of the reference image matches the
camera image of the playing surface.

5. To increase or decrease the opacity of the transparent overlay, move the Opacity slider to the
right or to the left.

6. To make fine adjustments to the corner points, press and hold the CTRL key, and move the
calibration points as required.
The dX and dY values turn green when the corner points are correctly calibrated.

7. Select Image-Based from the list.

8. If required, do any of the following.

• To set the camera exposure manually, clear the Enable Auto Exposure checkbox, and
move the slider.

• When mapping a playing surface, to mask moveable features visible to the camera that
are outside of the screen and not covered by the marked surface overlay, such as non-
fixed seating or advertising, select Use Screen as Mask. This option is available only with
the Pro Venue edition of Mystique Install.

9. Click Calibrate Cameras.

10. To take a new reference image, click Take Reference Image.

11. Click Run.
Christie Mystique Install saves this new reference image and uses it for automatic recalibration
each time you click Run.
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Testing image-based recalibration
Validate whether a camera can be successfully recalibrated to a reference image if it is accidentally
moved out of place.

To recalibrate a camera using this method, a reference image of the configuration must have been
previously taken using Mystique Install.
Christie recommends this method of recalibration when correcting for small motions of a fixed camera,
such as a building vibration. If the camera is moved to a new location or its view is significantly
altered, manually realign the camera for the new configuration and take a new reference image.

1. Open a configuration file.

2. In the left pane, click Calibration.

3. Select Image-Based from the list.

4. To test recalibration of the camera, click Calibrate Cameras (B).
If recalibration is successful, the alignment of the marked surface overlay matches the image
in the Camera View (A). If recalibration is unsuccessful, try adjusting the exposure or enable
the Use Screen as Mask setting.
Before

After
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Troubleshooting
Learn about common issues and their solutions.

Viewing and exporting diagnostics
Each time Mystique Install is run, a new folder for diagnostics files (such as log files or images) is
created.

When helping troubleshoot issues with Mystique Install, the Christie technical support team might ask
you to open and read diagnostic files, or to send those files to Christie for further analysis.

Viewing diagnostic files
Learn how to view diagnostic files.

1. Click Help > Diagnostics > View.

2. Select one of the following:

• Crash

• Data

• Images

• Logs

Exporting diagnostic files
Learn how to export diagnostic files.

1. Switch to the Help tab.

2. Click Export.

3. Select a Mystique Install session and click Export Diagnostics.

4. Browse to where the .zip archive file is to be saved and click Save.

5. Find the file on your computer.
The file name begins with ACDiags_ and, if you saved your calibration, it includes the
calibration file name and the session folder name. This file includes the date and time when
you launched Mystique Install.

6. Send the .zip archive file to the Christie technical support team.
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I cannot load Mystique Install on my computer
In some cases, computers running the Windows 8 operating systems cannot install the Bonjour
Service.

Resolution
If your computer is running Windows 8, install the following update, then try loading Mystique Install
again.

• Install the update located here: https://www.microsoft.com/en-us/download/details.aspx?
id=49082.

If your computer is running Windows 8.1, verify that all recommended Windows updates are installed,
then complete the following steps.

1. Install the update located here: https://support.microsoft.com/en-us/help/2919355/windows-
rt-8.1,-windows-8.1,-and-windows-server-2012-r2-update-april-2014.

2. Install the update located here: https://www.microsoft.com/en-us/download/details.aspx?
id=49082.

3. Load Mystique Install again.

Mystique Install cannot locate cameras or
projectors
To locate cameras or projectors in a configuration, try any of the following.

Resolution

• Confirm that the computer is connected to a network.

• Check the cable connections (computer, camera, projectors, etc.)

• Make sure that the computer is on the same subnet as the camera or projector.

• Try to access the projector's web interface. From the Select Projectors dialog, in the Manual
tab, type the IP address of the projector.

• On the projector, check the version of the Ethernet firmware.

• On the computer, check that no other Christie software application is running.

• On the computer, verify that the Bonjour application is installed and that it is operating as
expected.

I cannot connect to a camera
To connect a camera to a configuration, try the following.

Resolution
Make sure the camera is connected to a dedicated router with DHCP enabled. The camera should
automatically be assigned an IP address.

Troubleshooting
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If the Point Grey Flea3 camera cannot be detected on the network, try the following:

1. Disable all wireless network connections.

2. Connect one end of an Ethernet cable to the camera.

3. Connect the other end of the Ethernet cable into the network port of the computer running
Mystique Install.

4. Click Start > Programs > Christie > Mystique Install > Point Grey Utilities > GigE
Configurator.

5. In the left pane, select your camera.
If the camera isn't recognized, for diagnostic information, see the documentation provided by
the camera manufacturer.

6. Click Automatically Force IP.

7. Set the IP address and subnet for the camera.

• If the cameras use static IP addresses:

• Enter the network settings for the camera.

• Select LLA & Persistent IP.

• Click Set IP Address /Subnet.

• If the cameras use dynamic IP addresses:

• Select LLA & Persistent IP.

• Select DHCP.

• Click Set IP Address/Subnet.

8. Click Test Camera Connection.

9. Reconnect the camera to the network.

10. Click Test Camera Connection.

Mystique Install cannot communicate with a
connected device
If Mystique Install cannot connect to a camera or a Pandoras Box device, try the following.

Resolution
Disable the Windows Firewall on the computer while Mystique Install interfaces with the connected
device.

1. On the computer, navigate to Start > Control Panel > System and Security > Windows
Firewall.

2. In the left pane, click Turn Windows Firewall on or off.

3. Turn off Windows Firewall.

4. Click OK.
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An intermittent camera connection issue is
occurring
If the live camera preview is intermittently replaced by a checkerboard pattern, and the Mystique
Install calibration is also failing, you might be experiencing an intermittent camera connection issue.

Resolving an intermittent camera connection issue if network
(GigE) cameras are installed
If you experience an intermittent camera connection issue and network (GigE) cameras are installed,
complete the following.

Before you begin, complete the I cannot connect to a camera (on page 82) procedure.

Resolution
Make sure that the Point Grey filter driver is installed.

1. On your computer, open Control Panel > Network and Sharing Center .

2. In the left pane, click Change Adapter Settings.

3. Right-click the Ethernet or Local Area Connection icon and select Properties.
If installed, the filter driver appears as Point Grey Lightweight Filter Driver and, if enabled,
the checkbox next to the driver is selected.

If the the filter driver is not installed, from the Properties window, complete the following:

1. Click Install.

2. In the Select Network Feature Type window, select Service > Add.

3. In the Select Network Service window, click Have Disk.

4. In the Install From Disk window, click Browse.

5. Navigate to C:\Program Files\Christie Digital Systems\Mystique Install
2.1\PointGrey.

6. Select pgrlwf.inf, then click Open.

7. In the Install From Disk window, click OK.
The Select Network Service window is updated to indicate that you selected the Point Grey
Lightweight Filter Driver network service.

8. Click OK.
The Properties window is updated to indicate that the Point Grey Lightweight Filter Driver is
installed.

9. Click Done.

If you cannot install the filter driver, complete the following:

1. Click Start.

2. In the Search Programs and Files field, type regedit and click Enter.

3. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Network.

4. In the right pane, double-click MaxNumFilters.
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5. In the Value Data field, type 14.

6. Click OK.

Related information

I cannot connect to a camera (on page 82)

Mystique Install unexpectedly terminated after connecting to a network (GigE
Point Grey) camera
If Mystique Install unexpectedly terminates when a network (GigE Point Grey) camera is installed and
the control computer is running Windows 8.1, Christie recommends the following.

Resolution
1. Install the update located here: https://support.microsoft.com/en-us/help/2919355.

2. Restart Mystique Install.

Resolving an intermittent camera connection issue if USB
cameras are installed
It is recommended that the computer is restarted after each troubleshooting attempt.

Resolution

• Verify that the USB camera is not in use by the Point Grey Fly Capture application or another
instance of Mystique Install.

• Move the USB cable side to side and up and down. If this causes dropped frames, verify that
the USB cable is correctly attached or replace it altogether.

• On the control computer, connect the USB cable to a different USB port.

• Replace the USB cable.

• Install a shorter USB cable.

• Install a USB hub between the control computer and the camera.

A camera has drifted out of position
If a camera drifts over time, and Mystique Install cannot recalibrate based on the existing reference
image, you receive a dialog message indicating the camera must be repositioned.

Resolution
If you cannot physically access the camera, or cannot reposition it, try one of the following options.

• Disable automatic camera calibration. If you have a marked surface image, manually move the
calibration points to fit the live camera image, and then run a manual calibration. This does not
create a new reference image.

• Set new calibration points and then create a new reference image. This discards all settings
associated with the previous reference image.
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The projector is unresponsive
If the projector is unresponsive, try any of the following.

Resolution

• Check that the power source is turned on.

• Verify that all cables are connected.

• Check that the control computer can search for projectors.

The calibration file is invalid
To verify that a .cal file is valid, check the following.

Resolution
• The selected camera is connected to the network.

• The screen is defined.

• All projectors in the configuration are connected to the network.

High dx, dy values occur during camera
calibration
If you experience high dx, dy values during camera calibration, do not attempt to lower the calibration
error by moving calibration points away from the marker in the camera image.

Resolution
If the dx, dy values are greater than 1.0, try the following:

• In the image preview, adjust the 2D calibration points so that they match the markers or
screen corners.

If the tolerance remains greater than 1.0, try the following:

• Verify that the screen dimensions are correct.

• Verify that the 3D calibration points are correctly defined.

The alignment results are poor
If the alignment results are poor, try any of the following.

Resolution
• Verify that there is adequate camera coverage on the screen.
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• Verify that the camera is successfully calibrated.

• Review the exposure and binarization settings. If you selected automatic exposure and
binarization, select manual and adjust the values.

• Verify that all cameras are in focus.

• Verify that the camera images aren't over exposed. Click the Projector Control tab and click
Show in Markers. If necessary, adjust the camera aperture.

• In the left pane, expand Camera. Expand Exposure & Binarization, and then select
Automatic.

The camera performance is slow
For optimal results, you should have a minimum of a 1.0 Gigabits per second (Gbps) network
connection.

Resolution
Mystique Install reports the network health of each Ethernet camera in a configuration. To identify
which cameras are experiencing issues, or factors that might be contributing to poor camera
performance, you can view the summary in the Mystique Install status bar, or view information
specific to each camera under Camera > Details > Network Health.
To confirm the speed of the network connection:

1. Click Start > Control Panel > Network and Sharing Center.

2. To view the network settings, click a network connection.

The camera and reference image do not align
If the camera and reference images do not align, try any of the following.

Resolution
• Verify that the camera image is not inverted.

• Turn off any test patterns in the Projector Control tab to verify that Christie Mystique Install
sees the true image and not the projected image.

Mystique Install test patterns appear as expected
but alignment is poor
Test patterns generated by Christie Mystique Install appear as expected but alignment on the playing
surface is poor.

Details
This can occur if the layout in the media server does not match the layout specified in Mystique Install.
For example, if a 300 pixel overlap is specified in Mystique Install but the content is rendered with 295
pixels, a misalignment of at least five pixels occurs.
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Resolution
• Confirm your layout, and update the layout information in either the media server or in

Mystique Install.

I am receiving an error message
The following topics are common error messages might be received when installing or configuring
Mystique Install.

Mystique Install failed to determine a channel ordering
Channel ordering is only required with the Wallpaper (Simple) layout.

Resolution
• Verify that the layout settings are correct. The channel layout must match the projector

output.

• Verify that every projector is calibrated by the camera.

• Try High Contrast or Manual mode. In the left pane, click Camera. Expand the Exposure &
Binarization area. In the list, select High Contrast or Manual.

• Try using the Wallpaper (Advanced) layout. The Wallpaper (Advanced) layout is not available
with the Essentials edition of Mystique Install.

The mapper generated no data
If you receive an error indicating that the mapper generated no data, try any of the following.

Resolution

• Verify that each projector is calibrated by at least one camera.

• Remove the lens cap from all cameras.

• If you are in a dark room, a low aperture setting can result in a black image. To increase or
decrease light levels, adjust the camera aperture.

• Verify that the camera is pointing at an illuminated surface.

• Try to view the camera image using the software provided by the camera vendor. For example,
use FlyCapture with Point Grey cameras. The FlyCapture application is included with Mystique
Install.

• If you see a clear image with the camera software, but not with Mystique Install, verify
that the camera and firmware are supported, and contact the Christie Technical Support
team.

• If the image is visible but unclear, manually focus the camera.
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Warps have failed validation
If warps fail validation, try any of the following.

Resolution

• Open the .twistx file to determine which part of the system is problematic. To open a .twistx
file, at the top of the screen, click Home  > Twist.

• Warps that are reasonably accurate are likely associated with projectors that are calibrated
correctly.

• Warps that are reasonably linear but are off on the digital micromirror device can indicate
an incorrect or swapped channel.

• Warps that are missing or distorted can indicate that the camera cannot see the
corresponding projector as expected.

• Verify the layout settings are correct and that the orientation setting matches the projector
orientation settings.

• Adjust the projector orientation and mirroring so that the on-screen display appears correctly
when viewed from the planned end-user position.

A .Net framework initialization error occurred
If a .Net framework initialization error occurs when running the Point Grey Driver Control Utility,
complete the following.

Resolution

1. Navigate to C:\Program Files\Christie Digital Systems\Mystique Install
2.1\PointGrey.

2. Run the dotNetFx40_Clientx86_x64.exe file.

Projector undershooting is causing distorted
blends
Projector undershooting can occur if a projector undershoots the screen or content boundary. This
creates a region upon which only one projector can project an image.

Resolution
To correct this issue, in either the Wallpaper (Simple) or the Wallpaper (Advanced) layout, try one of
the following:

• To ignore projector undershoot around the border when performing blend calculations and
improve blend quality, in the left pane, expand Options > Twist. Select the Smart
Undershoot Handling checkbox.

• If you have an irregular projector or content arrangement, in the left pane, expand Options >
Twist. Clear the Smart Undershoot Handling checkbox. The other projector fills the
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undershoot area and modifies the blend so that it transitions smoothly in to the undershoot
region.

Points in alignment patterns are missing
The maximum number of points that a projector can draw is limited by the projector hardware. Some
alignment patterns can appear to be missing points, especially if the channel extents are large. This is
expected.

For example, a field of view alignment pattern displays a small colored box at every degree confluence
point. Degree confluence points are points in the channel where the horizontal and vertical degree
measurements are exact integers and occur where horizontal and vertical grid lines cross when placed
one-degree apart. Larger channel extents require that a greater number of points be drawn. This
number could exceed the number that the projector is capable of displaying.
If the number of degree confluence points exceeds the maximum number of points that the projector
can display, some points are removed from the pattern. The most relevant points, such as those on
90-degree grid lines, 5-degree major grid lines, or points that are closest to those grid lines are
displayed. Less relevant points that fall on minor grid lines might be removed from the test pattern.
Similar restrictions apply to projector centric test patterns. Points might be removed from the pattern
if there are too many points for a projector to display, or if the points are too close together.

An obstruction is appearing in the path of the
projector image
If an obstruction appears between a projector and the projection surface, create a mask to hide the
obstruction. Where possible, when creating a mask, Mystique Install blends the content around the
obstruction.

Resolution
To create a mask:

1. Switch to the Home tab.

2. To open Twist, click Twist.

3. Switch to the Mask layer tab.

4. On the canvas, click the projector window for the projector that is obstructed.

5. To adjust the shape of the mask, move one or more points toward the center of the projector
window.

6. To add a point, right-click on a grid line then select Add Point.

7. To send the mask to a projector, on the canvas, right-click a projector window then select
Send Mask.
The updated setting is saved to the projector memory.

8. On the projection surface, verify that the mask removes all projected light from the
obstruction. If it does not, repeat steps 5-7.

9. Repeat steps 4-8 for any additional projector impacted by an obstruction.

10. To save the mask as a configuration file, click File > Save.
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If the blend zone between two or more projectors is blocked by an obstruction, you can copy the Mask
layers to the Blend Mask layers for all impacted projectors.

1. Switch to the Mask layer tab.

2. Right-click a projector window then select Copy Mask.

3. In the left pane, expand the Blend Mask layer tab.

4. Click Blend Mask.

5. Right-click a projector window then select Paste Mask to Blend Mask.
The Blend layers for each projector are updated when Blend Masks are changed.

6. To send the updated blend to a projector, in the left pane, click Send.

To avoid overwriting the mask the next time you run Mystique Install, do the following:

1. In the left pane, expand Options.

2. In the Masking list, click From Twist File.

3. To prevent Mystique Install from calibrating against masked out obstructions in a configuration,
select Masked Mappers.
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For the most current technical documentation, visit www.christiedigital.com. 

Christie Digital Systems Canada Inc.
Kitchener
ph: 519 744 8005

Christie Digital Systems USA, Inc.
Cypress
ph: 714 236 8610

Corporate offi ces

United Kingdom
ph: +44  (0) 118 977 8000

United Arab Emirates
ph: +971 4 3206688

Spain
ph: +34 91 633 9990

Singapore
ph: +65 6877 8737

Republic of South Africa
ph: +27 (0)11 510 0094

Korea (Seoul)
ph: +82 2 702 1601

Japan (Tokyo)
ph: 81 3 3599 7481

India
ph: +91 (080) 6708 9999

Germany
ph: +49 2161 664540

France
ph: +33 (0) 1 41 21 44 04

Russian Federation
and Eastern Europe
ph: +36 (0) 1 47 48 100

China (Shanghai)
ph: +86  21 6278 7708

China (Beijing)
ph: +86 10 6561 0240

Brazil
ph: +55 (11) 2548 4753

Australia
ph: +61 (0) 7 3624 4888

Worldwide offi ces

Italy
ph: +39 (0) 2 9902 1161

Independant sales 
consultant offi ces

Mexico
ph: +52 55 4744 1790

United States (New York)
ph: 646 779 2014

United States (Arizona)
ph: 602 943 5700




	Content
	Getting started with Mystique Install
	Mystique Install editions
	System recommendations
	Computer and software requirements
	Network requirements
	Camera recommendations
	Choosing a camera

	Supported projectors

	Product documentation
	Related documentation

	Installing operating system patches
	Installing Mystique Install
	Ensuring port 80 is not in use
	Installing Mystique Operate Lite

	Connecting the control computer to a projector and a camera
	Workflows
	Smooth screen configuration workflows for 2D layouts
	Playing surface configuration workflows
	Structured light calibration workflow for 3D layouts
	ACT calibration workflow for 3D layouts
	Manual calibration workflow for 3D layouts

	Creating a Mystique Install configuration
	Opening an existing configuration

	Licensing Mystique Install
	Requesting an updated license
	Applying a new Mystique Install license

	Uninstalling Mystique Install
	Keyboard shortcuts
	Technical support

	Managing projectors
	Searching for a projector
	Manually adding a projector to a configuration
	Removing a projector from a configuration

	Identifying projectors in a configuration
	Reordering the projectors in a configuration
	Finding projector details
	Customizing default projector options
	Controlling a projector
	Connecting a Pandoras Box Manager as a projector
	Changing the order of channels in a configuration
	Renaming a channel
	Swapping channels

	Configuring cameras
	Adding a camera to a configuration
	Finding camera details
	Adding a camera profile
	Setting up the camera image
	Adjusting camera exposure and binarization
	Manually adjusting exposure and binarization

	Calibrating cameras
	Automatically calibrating the camera using a Christie ACT device
	Performing an image-based calibration
	Recalibrating the camera to a reference image

	Manually calibrating the camera
	Adding 3D points to the System View
	Locating the corners of a screen


	Adjusting the Camera View
	Adjusting an image in Camera View

	Removing a camera from a configuration

	Managing the image position and layout
	Setting up screen definitions
	Configuring a flat screen or a marked surface
	Automatically setting up a cylindrical screen
	Manually setting up a cylindrical screen
	Setting up a spherical screen
	Configuring a custom screen
	Using a laser scan file to set up a screen

	Setting the units of measure
	Adjusting the System View
	Defining the layout
	Defining a single-camera layout
	Specifying the properties of a multi-camera layout
	Defining the fields of view
	Changing the values in the Fields of View Channel Extents table

	Defining the collimated fields of view
	Correcting distortion

	Configuring the Projector Centric layout


	Performing a system calibration
	Confirming the configuration
	Analyzing the configuration
	Running a full system calibration
	Running a partial system calibration
	Selecting calibration options
	Masking a projector to a screen


	Evaluating the content alignment
	Displaying a test pattern
	Applying warps and blends to a test pattern
	Adjusting a warp or blend
	Accessing a saved warp
	Accessing a saved blend
	Configuring the options for Twist

	Creating a 3D layout
	Hardware requirements for 3D configurations
	Workflows
	Structured light calibration workflow for 3D layouts
	ACT calibration workflow for 3D layouts
	Manual calibration workflow for 3D layouts

	Manually adjusting camera gain and exposure
	Specifying a model
	Manually calibrating cameras
	Configuring and gathering structured light
	Generating the point cloud
	Cropping points from the point cloud

	Locating the model
	Solving the layout
	Exporting a 3D layout

	Drawing a 3D test pattern
	Applying blends to a 3D layout
	Recalibrating a 3D layout

	Configuring black level blending
	Loading a previously saved black level blend
	Estimating projector black levels
	Evaluating overall uniformity
	Adjusting the quality of a black level blend
	Saving a black level blend

	Maintaining the alignment of a projected image with Guardian
	Guardian requirements and limitations
	Configuring and starting a Guardian calibration
	Monitoring a Guardian calibration
	Adding scenes in Mystique Operate Lite
	Controlling Guardian from Mystique Operate Lite


	Mapping a playing surface
	Requirements for mapping a playing surface
	Adding devices to a configuration
	Searching for a projector
	Manually adding a projector to a configuration
	Connecting a Pandoras Box Manager as a projector
	Adding a camera to a playing surface configuration

	Defining the playing surface layout
	Defining a single-camera layout
	Specifying the properties of a multi-camera layout
	Mapping the marker points on a playing surface

	Calibrating the camera
	Calibrating a playing surface configuration manually
	Performing an image-based calibration on a playing surface
	Testing image-based recalibration



	Troubleshooting
	Viewing and exporting diagnostics
	Viewing diagnostic files
	Exporting diagnostic files

	I cannot load Mystique Install on my computer
	Mystique Install cannot locate cameras or projectors
	I cannot connect to a camera
	Mystique Install cannot communicate with a connected device
	An intermittent camera connection issue is occurring
	Resolving an intermittent camera connection issue if network (GigE) cameras are installed
	Mystique Install unexpectedly terminated after connecting to a network (GigE Point Grey) camera

	Resolving an intermittent camera connection issue if USB cameras are installed

	A camera has drifted out of position
	The projector is unresponsive
	The calibration file is invalid
	High dx, dy values occur during camera calibration
	The alignment results are poor
	The camera performance is slow
	The camera and reference image do not align
	Mystique Install test patterns appear as expected but alignment is poor
	I am receiving an error message
	Mystique Install failed to determine a channel ordering
	The mapper generated no data
	Warps have failed validation
	A .Net framework initialization error occurred

	Projector undershooting is causing distorted blends
	Points in alignment patterns are missing
	An obstruction is appearing in the path of the projector image


